upgraded to 4.0 from 3.6 - bombing adding new bug - undefined column reverse_desc

RESOLVED INVALID

Status

()

Bugzilla
Creating/Changing Bugs
--
critical
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: Mike Katz, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.127 Safari/534.16
Build Identifier: 4.0

i upgraded from v3.6 to 4.0 of bugzilla.  seems to be fine until i try to add a new bug - gets the following error message.  is there some sort of database upgrade/migration required?

DBD::mysql::db selectall_arrayref failed: Unknown column 'reverse_desc' in 'field list' [for Statement "SELECT id,name,description,type,custom,mailhead,sortkey,obsolete,enter_bug,buglist,visibility_field_id,visibility_value_id,value_field_id,reverse_desc,is_mandatory FROM fielddefs WHERE custom = ? AND obsolete = ?  ORDER BY sortkey, name"] at Bugzilla/Object.pm line 276
	Bugzilla::Object::_do_list_select('Bugzilla::Field', 'custom = ? AND obsolete = ?', 'ARRAY(0x1c696620)', 'undef') called at Bugzilla/Object.pm line 253
	Bugzilla::Object::match('Bugzilla::Field', 'HASH(0x1c696530)') called at Bugzilla/Field.pm line 258
	Bugzilla::Field::match('Bugzilla::Field', 'HASH(0x1c696530)') called at Bugzilla.pm line 554
	Bugzilla::active_custom_fields('Bugzilla') called at enter_bug.cgi line 401

Reproducible: Always

Steps to Reproduce:
1. upgrade to 3.6, copying the data directory and config file
2.  run the app
3.  click on add a new bug and select product
Actual Results:  
DBD::mysql::db selectall_arrayref failed: Unknown column 'reverse_desc' in 'field list' [for Statement "SELECT id,name,description,type,custom,mailhead,sortkey,obsolete,enter_bug,buglist,visibility_field_id,visibility_value_id,value_field_id,reverse_desc,is_mandatory FROM fielddefs WHERE custom = ? AND obsolete = ?  ORDER BY sortkey, name"] at Bugzilla/Object.pm line 276
	Bugzilla::Object::_do_list_select('Bugzilla::Field', 'custom = ? AND obsolete = ?', 'ARRAY(0x1c696620)', 'undef') called at Bugzilla/Object.pm line 253
	Bugzilla::Object::match('Bugzilla::Field', 'HASH(0x1c696530)') called at Bugzilla/Field.pm line 258
	Bugzilla::Field::match('Bugzilla::Field', 'HASH(0x1c696530)') called at Bugzilla.pm line 554
	Bugzilla::active_custom_fields('Bugzilla') called at enter_bug.cgi line 401

Comment 1

8 years ago
You forgot to run checksetup.pl.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 2

5 years ago
I did run the checksetup.pl but after this i am getting the same error message. I am unable to raise a new bug in updated bugzilla.

Comment 3

5 years ago
(In reply to Lokesh from comment #2)
> I did run the checksetup.pl but after this i am getting the same error
> message. I am unable to raise a new bug in updated bugzilla.

No need for a new bug. That's not the right place to get support. For help, please visit http://www.bugzilla.org/support.
You need to log in before you can comment on or make changes to this bug.