Not always the restore sessions works automatically

VERIFIED INVALID

Status

()

Firefox
Session Restore
--
enhancement
VERIFIED INVALID
7 years ago
7 years ago

People

(Reporter: Savio, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 ( .NET CLR 3.5.30729)

Sometimes I loss all my opened tabs. I don't know exactly the reason but I saw when my wife opened a new window (new instance) of Mozilla Firefox while my window stayed opened. So she closed my window (previous window), she did works, and soon closed the her window too. One day later, when I opened Firefox, all the tabs of my wife came in. I lost all my tabs and this was a big pain of head. I suggest the creation a new button on top of window (or menu item) where the user can save all the tabs opened (links) and to give a name to this saved session (the system will save the links in a file, for example). This way, since the previous user causes the lost of all the tabs of previous session, I can click in other menu item where appears all the saved sessions by name and choose one. Immediatly the Firefox will open all the links from that session.

Reproducible: Always

Steps to Reproduce:
1. Open an new instance of Firefox (window)
2. Open several links
3. Open a new instance
4. Open several links
5. Close the first window
6. Open more some links in second window
7. Close the second (last) window
Actual Results:  
When I open a new window I loss all my tabs previously opened (in first window mentioned above)

Expected Results:  
Allow save all the links in a file named by user to restore later.

Updated

7 years ago
Version: unspecified → 3.6 Branch
Firefox will restore the window(s) that were open when quitting. Since your wife's window was the last closed, that was restored.

Firefox allows you to restore recently closed windows via the history menu, so we do have the ability to recover "lost" windows.

Additionally, Firefox also allows you to bookmark all tabs open in a window and save them to a bookmarks folder.

Given that, we believe that there are ways to help with this. The ideas you suggest aren't bad, but are best left to an extension. I'd suggest searching addons.mozilla.org for one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
In my opinion, the standard behavior of Firefox about this is excelent but just for 1 user. When we have 2 or more users working your own tabs/windows separately the problem is iminent. I think visibles objects (like a buttons to save/restore sessions) in tool bar are more intuitives than a "bookmark" option. BTW (and like a constatation of I said before), where is and how use "bookmark" option to save/restore all my tabs in case of my wife explode them? It's not intuitive to me, sorry.
(In reply to comment #2)
> In my opinion, the standard behavior of Firefox about this is excelent but just
> for 1 user. When we have 2 or more users working your own tabs/windows
> separately the problem is iminent. I think visibles objects (like a buttons to
> save/restore sessions) in tool bar are more intuitives than a "bookmark"
> option. BTW (and like a constatation of I said before), where is and how use
> "bookmark" option to save/restore all my tabs in case of my wife explode them?
> It's not intuitive to me, sorry.

If multiple users are using Firefox, it's better to use the Profile Manager to manage these different users.  There is no easy way to safeguard multiple users on the same profile.

http://kb.mozillazine.org/Profile_manager
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.