Last Comment Bug 640065 - "Tabs from other windows" text disappears with background window
: "Tabs from other windows" text disappears with background window
Status: RESOLVED FIXED
[4rc][fixed-in-fx-team]
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: x86 Mac OS X
: P4 normal
: Firefox 10
Assigned To: Raymond Lee [:raymondlee]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-08 18:39 PST by Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Modified: 2016-04-12 14:00 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot (14.17 KB, image/png)
2011-03-08 18:39 PST, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
v1 (715 bytes, patch)
2011-08-16 21:59 PDT, Raymond Lee [:raymondlee]
ttaubert: review+
limi: ui‑review+
Details | Diff | Splinter Review
Mac Resizer Screenshot (4.88 KB, image/jpeg)
2011-08-17 06:43 PDT, Raymond Lee [:raymondlee]
no flags Details
Search screenshot (9.12 KB, image/png)
2011-08-17 07:26 PDT, Raymond Lee [:raymondlee]
no flags Details
Search screenshot 2 (background window) (8.88 KB, image/png)
2011-08-17 09:13 PDT, Raymond Lee [:raymondlee]
no flags Details
Patch for checkin (991 bytes, patch)
2011-10-11 05:13 PDT, Raymond Lee [:raymondlee]
no flags Details | Diff | Splinter Review

Description Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-03-08 18:39:17 PST
Created attachment 517952 [details]
Screenshot

When searching for tabs from other windows from within Panorama, there is text which says "Tabs from other windows".  This text disappears if this window loses focus.

Steps:
1. Open a few tabs in the main window to different pages
2. Open a new window
3. Open the Tab Groups view
4. Click the search button
5. Type the name of one of the loaded pages
6. Click the main window

Result:
"Tabs from other windows" text disappears.

Expected:
"Tabs from other windows" text should dim but still be visible.
Comment 1 B.J. Herbison 2011-03-09 06:55:47 PST
I don't see this issue on Windows XP. As I type another window still says "Tabs from other windows" in the bottom.

Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-03-09 08:09:32 PST
As reported by the Platform fields of this bug, I've only seen this on Mac.  I have not had  a chance to verify on Windows and Linux yet.  Also, this was checked with the 4.0rc1 build, not a nightly.
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-03-09 08:15:51 PST
Seems to work fine on Linux as well -- looks like a Mac-only bug.
Comment 4 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-03-09 08:27:06 PST
I'll try to find a regression window for this bug.
Comment 5 Raymond Lee [:raymondlee] 2011-08-16 21:59:40 PDT
Created attachment 553678 [details] [diff] [review]
v1

Tested it on Linux, windows and Mac OSX and I only see the issue on Mac OSX.  This is the trivial patch to fix this.
Comment 6 Tim Taubert [:ttaubert] 2011-08-17 03:03:45 PDT
Comment on attachment 553678 [details] [diff] [review]
v1

Review of attachment 553678 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! The change looks good to me. Is that a color code we already use somewhere? If not could you please post a screenshot and for ui-review?
Comment 7 Raymond Lee [:raymondlee] 2011-08-17 06:43:00 PDT
Created attachment 553750 [details]
Mac Resizer Screenshot
Comment 8 Raymond Lee [:raymondlee] 2011-08-17 06:44:39 PDT
Comment on attachment 553678 [details] [diff] [review]
v1

Please check the "Mac Resizer Screenshot" to see whether it's ok or not
Comment 9 Tim Taubert [:ttaubert] 2011-08-17 06:46:50 PDT
(In reply to Raymond Lee [:raymondlee] from comment #8)
> Please check the "Mac Resizer Screenshot" to see whether it's ok or not

Are you sure that's the right screenshot for the right bug? ;)
Comment 10 Raymond Lee [:raymondlee] 2011-08-17 07:26:40 PDT
Created attachment 553761 [details]
Search screenshot

Ooops, I was thinking other bug. Here is the right one!
Comment 11 Raymond Lee [:raymondlee] 2011-08-17 09:13:25 PDT
Created attachment 553796 [details]
Search screenshot 2 (background window)
Comment 12 Raymond Lee [:raymondlee] 2011-10-11 03:01:37 PDT
limi:  very trivial patch, could you review it please.  Thanks?
Comment 13 Alex Limi (:limi) — Firefox UX Team 2011-10-11 03:13:17 PDT
Comment on attachment 553678 [details] [diff] [review]
v1

LGTM!
Comment 14 Raymond Lee [:raymondlee] 2011-10-11 05:13:56 PDT
Created attachment 566174 [details] [diff] [review]
Patch for checkin

Pushed to try and waiting for the results
https://tbpl.mozilla.org/?tree=Try&rev=836cbbf5ac8a
Comment 15 Raymond Lee [:raymondlee] 2011-10-11 08:49:45 PDT
(In reply to Raymond Lee [:raymondlee] from comment #14)
> Created attachment 566174 [details] [diff] [review] [diff] [details] [review]
> Patch for checkin
> 
> Pushed to try and waiting for the results
> https://tbpl.mozilla.org/?tree=Try&rev=836cbbf5ac8a

Passed Try!
Comment 16 :Felipe Gomes (needinfo me!) 2011-10-11 14:44:05 PDT
https://hg.mozilla.org/integration/fx-team/rev/2f0ace471a17
Comment 17 Rob Campbell [:rc] (:robcee) 2011-10-13 09:43:52 PDT
https://hg.mozilla.org/mozilla-central/rev/2f0ace471a17

Note You need to log in before you can comment on or make changes to this bug.