Crash in nsView::SetDimensions()

VERIFIED DUPLICATE of bug 63243

Status

()

--
critical
VERIFIED DUPLICATE of bug 63243
18 years ago
18 years ago

People

(Reporter: jst, Assigned: kmcclusk)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Try loading the above URL, I crash (using a mozilla build from last week) when
nsView calls mWindow->Resize(), here's the stacktrace:

ffff0393()
NPSWF32! 0485b904()
NPSWF32! 0485abd1()
USER32! 77e163fb()
USER32! 77e174c2()
NTDLL! 77f9f04b()
nsView::SetDimensions(nsView * const 0x03db3ab0, int 11700, int 1305, int 1)
line 606
nsViewManager2::ResizeView(nsViewManager2 * const 0x045a19e0, nsIView *
0x03db3ab0, int 11700, int 1305) line 1688
nsLineLayout::ReflowFrame(nsIFrame * 0x012e7b70, nsIFrame * * 0x0012d6f4,
unsigned int & 0, nsHTMLReflowMetrics * 0x00000000, int & 0) line 1112
nsInlineFrame::ReflowInlineFrame(nsIPresContext * 0x04585240, const
nsHTMLReflowState & {...}, nsInlineFrame::InlineReflowState & {...}, nsIFrame *
0x012e7b70, unsigned int & 0) line 598 + 26 bytes
nsInlineFrame::ReflowFrames(nsIPresContext * 0x04585240, const nsHTMLReflowState
& {...}, nsInlineFrame::InlineReflowState & {...}, nsHTMLReflowMetrics & {...},
unsigned int & 0) line 412 + 28 bytes
nsInlineFrame::Reflow(nsInlineFrame * const 0x012e79d0, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 323 + 28 bytes
nsLineLayout::ReflowFrame(nsIFrame * 0x012e79d0, nsIFrame * * 0x0012e3bc,
unsigned int & 0, nsHTMLReflowMetrics * 0x00000000, int & 0) line 921
nsBlockFrame::ReflowInlineFrame(nsBlockReflowState & {...}, nsLineLayout &
{...}, nsLineBox * 0x012e7550, nsIFrame * 0x012e79d0, unsigned char *
0x0012d934) line 4363 + 29 bytes
nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState & {...}, nsLineLayout &
{...}, nsLineBox * 0x012e7550, int * 0x0012dfb0, unsigned char * 0x0012ddf8, int
0, int 1) line 4247 + 28 bytes
nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState & {...}, nsLineBox *
0x012e7550, int * 0x0012dfb0, unsigned char * 0x0012ddf8, int 0, int 1) line
4181 + 42 bytes
nsBlockFrame::ReflowInlineFrames(nsBlockReflowState & {...}, nsLineBox *
0x012e7550, int * 0x0012dfb0, int 1, int 0) line 4126 + 32 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x012e7550, int
* 0x0012dfb0, int 1) line 3260 + 29 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2949 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x012230d0, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1740 + 15 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason
eReflowReason_Dirty, nsIFrame * 0x012230d0, const nsRect & {...}, int 1, int 0,
int 1, nsMargin & {...}, unsigned int & 0) line 562 + 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x012230d0, const nsRect & {...},
int 1, int 0, int 1, nsMargin & {...}, unsigned int & 0) line 332 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x0122311c, int * 0x0012eae8) line 3879 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x0122311c, int
* 0x0012eae8, int 1) line 3142 + 23 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2949 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x01223084, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1740 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x01223084, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
CanvasFrame::Reflow(CanvasFrame * const 0x0120ed94, nsIPresContext * 0x04585240,
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 306
nsBoxToBlockAdaptor::Reflow(nsBoxLayoutState & {...}, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0, int 0, int 0, int 12930, int 11505, int 1) line 868
nsBoxToBlockAdaptor::DoLayout(nsBoxToBlockAdaptor * const 0x01223018,
nsBoxLayoutState & {...}) line 525 + 52 bytes
nsBox::Layout(nsBox * const 0x01223018, nsBoxLayoutState & {...}) line 1002
nsScrollBoxFrame::DoLayout(nsScrollBoxFrame * const 0x0120eeac, nsBoxLayoutState
& {...}) line 379
nsBox::Layout(nsBox * const 0x0120eeac, nsBoxLayoutState & {...}) line 1002
nsContainerBox::LayoutChildAt(nsBoxLayoutState & {...}, nsIBox * 0x0120eeac,
const nsRect & {...}) line 593 + 16 bytes
nsGfxScrollFrameInner::LayoutBox(nsBoxLayoutState & {...}, nsIBox * 0x0120eeac,
const nsRect & {...}) line 1029 + 17 bytes
nsGfxScrollFrameInner::Layout(nsBoxLayoutState & {...}) line 1112
nsGfxScrollFrame::DoLayout(nsGfxScrollFrame * const 0x0120ee04, nsBoxLayoutState
& {...}) line 1037 + 15 bytes
nsBox::Layout(nsBox * const 0x0120ee04, nsBoxLayoutState & {...}) line 1002
nsBoxFrame::Reflow(nsBoxFrame * const 0x0120edcc, nsIPresContext * 0x04585240,
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 789
nsGfxScrollFrame::Reflow(nsGfxScrollFrame * const 0x0120edcc, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 741 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0120edcc, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x0120ed58, nsIPresContext *
0x04585240, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 546
nsHTMLReflowCommand::Dispatch(nsHTMLReflowCommand * const 0x045e5c50,
nsIPresContext * 0x04585240, nsHTMLReflowMetrics & {...}, const nsSize & {...},
nsIRenderingContext & {...}) line 146
PresShell::ProcessReflowCommands(int 1) line 5106
ReflowEvent::HandleEvent() line 4989
HandlePLEvent(ReflowEvent * 0x045d4d30) line 5003
PL_HandleEvent(PLEvent * 0x045d4d30) line 576 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00558d40) line 509 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000905ea, unsigned int 49373, unsigned int 0,
long 5606720) line 1054 + 9 bytes

This works in NS6 and older mozilla builds (don't know any dates of the older
builds)...
(Reporter)

Updated

18 years ago
Keywords: crash
(Reporter)

Updated

18 years ago
Blocks: 57896

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 63243 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe of bug 63243: "Browser crashes on visiting any page with flash
content"
Same stack trace (the page has flash content)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.