mail.msf is being created for the mail folder, shouldn't be

VERIFIED WONTFIX

Status

P3
normal
VERIFIED WONTFIX
20 years ago
10 years ago

People

(Reporter: esther, Assigned: Bienvenu)

Tracking

Trunk
Future
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Using builds 19990513 (May 13th and before), a .msf file is being created for
the mail folder, according to Seth it shouldn't be.
(Reporter)

Comment 1

20 years ago
Steps:

1. Launch Apprunner the first time.
2. Open Task|Messenger
3. Close Messenger and Apprunner
4. Go to the User directory for the account you just used and notice there is a
mail.msf file created at the Mail folder level.

Updated

20 years ago
Target Milestone: M7

Comment 2

20 years ago
this isn't hurting anyone right now

Comment 3

20 years ago
Is this a release note candidate for M6 then?  I'm tracking all of this for
input to verah later on.

Comment 4

20 years ago
Yes..

Comment 5

20 years ago
In thinking about this further, I don't think we need to release note this.
Once this bug is fixed, we should release note on how to remove this extra file.

Comment 6

19 years ago
if its not hurting anyone lets get it off the m7 list

Updated

19 years ago
Target Milestone: M7 → M8

Comment 7

19 years ago
I was thinking the same thing as I drifted off to sleep last night.
Keep this in the release notes for M7.

Comment 8

19 years ago
This bug reference is not in the release notes now.  I think we should release
note when it's fixed to tell people how to remove the extra .msf file.

Comment 9

19 years ago
going on vacation, mass-moving these M8 bugs to M9

Comment 10

19 years ago
moving low priority, high risk, and time-intensive bugs to M10

Updated

19 years ago
Target Milestone: M10 → M13

Comment 11

19 years ago
this is still so minor. I'll fix this during the bug fixing for b1

Updated

19 years ago
Whiteboard: [PR1]

Comment 12

19 years ago
Should probably fix this for PR1

Comment 13

19 years ago
*** Bug 6406 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
ok, to fix this I'll be adding a "isServer" attribute to the folder. this means
I'll probably have to parse the URI early, but that allows us to cache other
information

eventually it would be nice to have RDF resource factories to make the root
folders nsIMsgIncomingServer folders based on the scheme of the URI.

Comment 15

19 years ago
Note: when verifying, check case in duplicate bug as well.

Updated

19 years ago
Target Milestone: M13 → M12

Comment 16

19 years ago
M12; can't have M13 bugs right now.

Updated

19 years ago
Target Milestone: M12 → M14
(Reporter)

Updated

19 years ago
QA Contact: lchiang → esther

Updated

19 years ago
Whiteboard: [PR1]

Comment 17

19 years ago
*** Bug 23364 has been marked as a duplicate of this bug. ***

Comment 18

19 years ago
not a blocker, m15 (this poor bug...)
Target Milestone: M14 → M15

Comment 19

19 years ago
wow, this bug is almost one year old :-)

Comment 20

19 years ago
heh, yes pushed back almost 10 milestones now.

Comment 21

19 years ago
quietly moving this WAY out so the poor bug stops slipping and starts realizing
it won't be fixed any time soon.
Target Milestone: M15 → M20

Comment 22

19 years ago
quietly, huh? Ok, Esther and I won't tell anyone :-)

Comment 23

19 years ago
I'm going to try this bug when I get a chance.  I think it's probably gone by 
now.

Comment 24

19 years ago
it would surprise me if it's gone.
All you should have to do is click on the server, and it should create the .msf

Comment 25

18 years ago
Yep, still there.  0 byte file, probably harmless.  Move to Future.
Target Milestone: M20 → Future
(Assignee)

Comment 26

18 years ago
taking from Alec. This has always bugged me.
Assignee: alecf → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 27

18 years ago
accepting
(Assignee)

Comment 28

18 years ago
I believe this is fixed now - I fixed imap not to create .msf files for the
servers, and clicking on a server now loads the account central page, so between
these two things., I think this is fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 29

18 years ago
Using build 2001-04-30 on win, mac and linux, I still see this .msf file for the 
imap servers.  
1. Create a new profile
2. Add an IMAP account (mine is 3qatest07 with nsmail-2 as the server)
3. Log into that account, Exit the product.

Check the directory stucture for Windows for this profile.  I see 
...Profiles|Bug 6402|xyz.slt|ImapMail  Under this folder is a nsmail-2 folder 
and a nsmail-2.msf file. 

I added a POP mail account and did not see a .msf file created for that server. 
Reopening, this is not a critical bug, but it's not fixed as I understand it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
actually, I think we need server.msf files now.

if we are storing open closed state in the .msf file, we need one for the 
server.

right, bienvenu?
(Assignee)

Comment 31

17 years ago
yes, good point - marking wont fix
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

17 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 32

17 years ago
Great! I can get this one off the list and evaluate others that were tagged as 
duplicates to see if they are the same.  Verified!
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.