Toolbar icon briefly appear on startup with TP enabled

RESOLVED WONTFIX

Status

Mozilla Labs Graveyard
Test Pilot
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: tracy, Assigned: Jono Xia)

Tracking

Details

(Whiteboard: needs-integration, landed?)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 518126 [details]
toolbar icon cluster on startup

Seen with 1.1pre6 on XP and Win7

It's very quick, but does appear briefly on each startup with the latest version of TP enabled. If TP is disabled the bug goes away.

See attachment for screen shot
(Assignee)

Comment 1

7 years ago
Yeah I see this on Mac too. Looks like a regression since 1.1pre5.  I think I can fix it by putting back on one of the css files I removed.
(Reporter)

Comment 2

7 years ago
looks fixed in 1.1pre7 build
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

7 years ago
Created attachment 524915 [details] [diff] [review]
Patch to mozilla-central to fix this bug
Assignee: nobody → jdicarlo
Status: RESOLVED → REOPENED
Attachment #524915 - Flags: review?(mark.finkle)
Resolution: FIXED → ---
(Assignee)

Updated

7 years ago
Whiteboard: needs-integration
Comment on attachment 524915 [details] [diff] [review]
Patch to mozilla-central to fix this bug

based on comment 2 this looks to be fixed, but I have very little context to go on here. I assume something in feedback.css was breaking a moz-image-region rule.

Can you give me some hints as to why the change fixed the bug?
(Assignee)

Comment 5

7 years ago
mfinkle:  There was an earlier bug where text was appearing in an unreadable color (white on white) on Windows because a CSS style was being applied where it didn't belong.  Removing both of the CSS includes from browser.xul fixed this problem, but introduced the problem described above in this bug, that the toolbar icon cluster showed on startup.  So I made a second change to put back in one of the two CSS includes.

To save on patches, I bundled both changes into a single patch and attached to this bug because it was more recent.

It is actually the white-text-on-white that is fixed by the resulting combi-patch.  Sorry for the confusion.
Attachment #524915 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 6

7 years ago
Landed?
Whiteboard: needs-integration → needs-integration, landed?
Product: Mozilla Labs → Mozilla Labs Graveyard
decommissioned
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.