"Error Decrypting Record"



Cloud Services
Firefox Sync: Crypto
7 years ago
6 years ago


(Reporter: gkoberger, Unassigned)


Firefox Tracking Flags

(Not tracked)




7 years ago
As of this week, I'm no longer able to sync with any of my computers/phone.

I get the generic "Sync encountered an error while syncing: Unknown error.", which won't go away.

In the error console, I get the following errors:


I'm using Minefield 4.0b13pre (2011-03-03) on OSX.  I've tried deactivating and reactivating my account, with no luck.  Android says it's perpetually "In progress..".  Firefox 3.6 fails silently.
Hi Gregory, it seems like there's some data on the server that's encrypted with a different key.  The easiest fix for this should be to just wipe the server cache and let the clients recreate everything.  To do this, go to https://account.services.mozilla.com/ and log in with your username/password, and then go to "Clear your Sync data" and then do a new sync.

Comment 3

7 years ago
Hey Mike:

I managed to fix it myself by purging my data, clearing my history on all my computers, and syncing again.  I filed the bug because it seems like an issue that should be addressed- most people wouldn't know how to do this, and would just give up.


Comment 4

7 years ago
Additionally, I should mention that purging my data wasn't enough- I could sync the first time, but the second sync always failed.  This makes me think there was something in my history that sync didn't like.  It only worked after I cleared my history.

Comment 5

6 years ago
Closing since I haven't seen this in 10 months. Thanks :)
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.