If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Fx4MobileLaunch] Add Customize page to mobile site

RESOLVED FIXED in 2.3

Status

www.mozilla.org
General
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: Caitlin Looney, Assigned: Stephen DesRoches)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Currently the mobile site points directly to AMO from "Customize" in the site's drop-down menu. Soon after launch, I'd like to duplicate the Customize page on the desktop's site save for some rearranging and copy edits (http://www.mozilla.com/en-US/firefox/customize/)

1. Change top, left green download button to mobile download button.

2. Flip flow the top sections so Add-ons is top and Personas bottom.

3. Under Customize with Add-ons header, change the copy to: "Choose from hundreds of ways to add features, extend functionality and make Firefox work for exactly the way you use the Web on your phone. See some of our favorite below! Get these and more right from your Add-ons Manager in Firefox for mobile." [We can show new AMO site with top recommended showing]

4. Under the Personas header, please add "Easy-to-install themes that help you personalize the look of your Firefox on the go. Just install the Personas add-on and go right to the gallery from your mobile Start page."

Updated

7 years ago
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → 1.5

Comment 1

7 years ago
Hey John - what is the earliest work can start on this bug?
(Reporter)

Comment 2

7 years ago
Hey John - would love to know if this is possible for 1.5 or beyond. Thanks!

Comment 3

7 years ago
It's definitely possible for either 1.5 or the next release. At this point it's hard to say which b/c we're not finished with 1.4 yet and potentially have to make a pretty quick turn into 1.5.

Laura is probably a better person to speak to the specifics of when...LF, what do you think?

Comment 4

7 years ago
(In reply to comment #3)
> It's definitely possible for either 1.5 or the next release. At this point it's
> hard to say which b/c we're not finished with 1.4 yet and potentially have to
> make a pretty quick turn into 1.5.
> 
> Laura is probably a better person to speak to the specifics of when...LF, what
> do you think?

I can see this possibly launching with 1.5 if all that's required is the above. A couple of questions for Caitlin or Dan to make sure I understand the scope of this request:

1. Will any of the Personas on the current /customize page need to change?
2. What specific mobile add-ons will be used where the current categories (Traveler's Pack, Reference Desk, Sports Fanatic...) are now?
Summary: Add Customize page to mobile site → [Fx4MobileLaunch] Add Customize page to mobile site

Comment 5

7 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > It's definitely possible for either 1.5 or the next release. At this point it's
> > hard to say which b/c we're not finished with 1.4 yet and potentially have to
> > make a pretty quick turn into 1.5.
> > 
> > Laura is probably a better person to speak to the specifics of when...LF, what
> > do you think?
> 
> I can see this possibly launching with 1.5 if all that's required is the above.
> A couple of questions for Caitlin or Dan to make sure I understand the scope of
> this request:
> 
> 1. Will any of the Personas on the current /customize page need to change?
> 2. What specific mobile add-ons will be used where the current categories
> (Traveler's Pack, Reference Desk, Sports Fanatic...) are now?

Hey Caitlin - any update on the above? The timing here is looking tight. Assigning to you until these details are finalized.
Assignee: nobody → clooney
(Reporter)

Comment 6

7 years ago
1. No
2. I can provide 3 or so add-ons to feature. If so, could we get this page up?

Twitter Bar: https://addons.mozilla.org/en-US/mobile/addon/twitterbar/
Quit Firefox for Mobile: https://addons.mozilla.org/en-US/mobile/addon/quit-fennec/
Easy Reading: https://addons.mozilla.org/en-US/mobile/addon/easy-reading/
(Reporter)

Comment 7

7 years ago
The category can be called "Popular"

We don't have the Plugins or Adapt your Interface section.

Comment 8

7 years ago
Moving to 2.0 since it isn't launch critical. 

Question for John - Do you think new graphics will be needed to represent the add-on icons? Or is that something webdev should be able to gather from existing site assets? I ask since each of the current add-ons on this page http://www.mozilla.com/en-US/firefox/customize/ are represented by copy and their graphic icon.
Target Milestone: 1.5 → 2.0

Comment 9

7 years ago
(In reply to comment #8)
> Question for John - Do you think new graphics will be needed to represent the
> add-on icons? Or is that something webdev should be able to gather from
> existing site assets? I ask since each of the current add-ons on this page
> http://www.mozilla.com/en-US/firefox/customize/ are represented by copy and
> their graphic icon.

Good question. Right now those icons represent each section within the page (personas, add-ons, plugins, etc) rather than specific add-ons. As long as the mobile version retains the same basic structure and doesn't talk about completely different topics then we should be fine reusing them. 

If we need to create some new icons, it isn't particularly hard, but would add a little extra time onto the process.
(Reporter)

Updated

7 years ago
Blocks: 646517

Updated

7 years ago
Target Milestone: 2.0 → 2.1

Updated

7 years ago
Assignee: clooney → steven
(Assignee)

Comment 10

7 years ago
I have created the start of this page in r87426

1. Mobile > Customization now has it's own page and does not link directly to the add-ons site

2. I have flipped the order of Add-ons and Personas including the new descriptions.

3. The green download button has been change to the mobile button

4. Are we keeping the Plugins and Adapt Your Interface sections?
Assignee: steven → stephen

Comment 11

7 years ago
Stephen, can you include a link so we can review?
(Assignee)

Comment 12

7 years ago
Sure. http://www-trunk.stage.mozilla.com/en-US/mobile/customize/

Comment 13

7 years ago
Thanks Stephen. This is a good start, but it seems like some of the content here still needs to be updated for the mobile product (such as the personas screenshot).

Caitlin, can you advise?
(Assignee)

Comment 14

7 years ago
yes, The content absolutely needs to be reviewed and updated.  This commit was based on what was currently available in bug to get things started.

Comment 15

7 years ago
I figured as much. I also just heard that Caitlin is out until Wednesday, so we can pick this up when she's back.
Moving to 2.2 milestone since Caitlin isn't back during the 2.1 release cycle.
Target Milestone: 2.1 → 2.2

Comment 17

7 years ago
Moving to 2.3. We still need more detail before we can proceed here.
Target Milestone: 2.2 → 2.3

Comment 18

7 years ago
Hey guys - I had some feedback, but please wait for Caitlin's approval first before moving forward:

Feedback from me

1. Change "Get add-ons on your mobile, too! Just use the Add-ons Manager on your Android device or Nokia N900 to search and install."

to - "Get add-ons on your mobile! Just use the Add-ons Manager on your Android device or Nokia N900 to search and install."

2. We're not likely to have enough quality add-ons for this page. Can we drop the 'Online Shopping', 'Reference Desk' and 'Travel Help' tabs. Then replace "Starter Pack" with "Mobile Starter Pack"
- Replace the three existing add-ons with:
a. Phony: View mobile or desktop versions of the sites you visit.
b. Quit Firefox: Exit Firefox by closing all tabs or choosing "Quit" from the menu.
c. Foursquare: Check-in. Find your friends. Unlock your city.

3. Replace text under "Customize: ADD-ONS"
- Add features, extend functionality and make Firefox work on the move exactly the way you want it too. See some of our favorite below! Get these and more right from your Add-ons Manager in Firefox for mobile.

4. Change Desktop Personas with screenshot. Can we use a Samsung Galaxy S as the handset? Caitlin if you're happy with this, can you supply the screenshot?

5. Remove "Make it Work" (Plug-in) section altogether
(Reporter)

Comment 19

7 years ago
(In reply to comment #18)
> Hey guys - I had some feedback, but please wait for Caitlin's approval first
> before moving forward:
> 
> Feedback from me
> 
> 1. Change "Get add-ons on your mobile, too! Just use the Add-ons Manager on
> your Android device or Nokia N900 to search and install."
> 
> to - "Get add-ons on your mobile! Just use the Add-ons Manager on your Android
> device or Nokia N900 to search and install."

Work for me. 
> 
> 2. We're not likely to have enough quality add-ons for this page. Can we drop
> the 'Online Shopping', 'Reference Desk' and 'Travel Help' tabs. Then replace
> "Starter Pack" with "Mobile Starter Pack"
> - Replace the three existing add-ons with:
> a. Phony: View mobile or desktop versions of the sites you visit.
> b. Quit Firefox: Exit Firefox by closing all tabs or choosing "Quit" from the
> menu.
> c. Foursquare: Check-in. Find your friends. Unlock your city.

For c, please replace Foursquare with "Adblock Plus: Remove ads and view the Web exactly the way you'd like."
> 
> 3. Replace text under "Customize: ADD-ONS"
> - Add features, extend functionality and make Firefox work on the move exactly
> the way you want it too. See some of our favorite below! Get these and more
> right from your Add-ons Manager in Firefox for mobile.

Change slightly to: "Add features, functionality and personalize Firefox exactly the way you want. See some of our favorite below! Get these and more right from your Add-ons Manager in Firefox for mobile."
> 
> 4. Change Desktop Personas with screenshot. Can we use a Samsung Galaxy S as
> the handset? Caitlin if you're happy with this, can you supply the screenshot?

We have high-res images of an Android phone without the branding. What screen shot were you thinking, Dan? We don't currently have a touch friendly version of GetPersonas, but can probably figure out something zoomed in. 
> 
> 5. Remove "Make it Work" (Plug-in) section altogether

AGREED.

Comment 20

7 years ago
That all sounds good to me. Stephen, do you have what you need to continue or do you need further info?

Seems like the main remaining loose end is the image for Personas. Caitlin, how can we get that screenshot?
(Assignee)

Comment 21

7 years ago
Everything it good and ready to commit. Waiting on two things.

1. Screenshots being discussed between Dan and Caitlin.

"We have high-res images of an Android phone without the branding. What screen
shot were you thinking, Dan? We don't currently have a touch friendly version
of GetPersonas, but can probably figure out something zoomed in. "

2. And just so it's clear, links for Phony, Quit Firefox and Adblock Plus.

https://addons.mozilla.org/af/mobile/addon/phony/
https://addons.mozilla.org/en-us/firefox/addon/quit-firefox/
https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/


The regular page (http://www.mozilla.com/en-US/firefox/customize/) was using a tracker on the end of each link (?src=mozcom-personalize). Should I continue to use it here too?

Comment 22

7 years ago
Thanks Stephen. Caitlin & Dan, can you advise on comment #21?

Comment 23

7 years ago
Back from holiday - sorry for the delay in my reply. Re: screenshot - suggest we use one of the popular ones, like Japanese Tattoo (my favourite) - http://www.getpersonas.com/en-US/persona/7610

Can we load up the Firefox Start page, and swipe the page right to show the tools. That will expose the Persona behind both the awesome bar -and- the tools column

Comment 24

7 years ago
This may be a stupid question, but how do we get that screenshot? Mobile screenshots aren't my forte.
(Assignee)

Comment 25

7 years ago
Changes have been committed in r87872 & r87873

We took a shot at creating the screenshot. Does this work?

I'm still not sure the "Adapt Your Interface" section belongs on the mobile page. Should this have been removed?

http://www-trunk.stage.mozilla.com/en-US/mobile/customize/

Comment 26

7 years ago
(In reply to comment #25)
> We took a shot at creating the screenshot. Does this work?
Awesome, thanks! Caitlin & Dan - what do you think? My only concern is that, although showing the side nav reveals more of the persona, it also feels a bit off center. Your call.
 
> I'm still not sure the "Adapt Your Interface" section belongs on the mobile
> page. Should this have been removed?
Seems like it should be, but Caitlin/Dan please confirm.
(Reporter)

Comment 27

7 years ago
I don't see the link or attachment...
(Reporter)

Comment 28

7 years ago
Apologies...I see now. (http://www-trunk.stage.mozilla.com/en-US/mobile/customize/)

Actually - this view is probably the best you'll be able to see your persona other than in the controls view on the Awesome Screen. This looks fine to keep, IMO.

Comment 29

7 years ago
Ok, that sounds good to me. Can we delete Adapt Your Interface then?
(In reply to comment #29)
> Ok, that sounds good to me. Can we delete Adapt Your Interface then?

Caitlin - can you confirm? Thanks.
(Reporter)

Comment 31

7 years ago
Confirmed. Thanks.

Comment 32

7 years ago
Steven - This looks good on Trunk. Now that Caitlin's confirmed, is this page ready to go in the release today?
(Assignee)

Comment 33

7 years ago
Adapt your interface has been removed in r88206.

After review, this is good to go.
Merged to stage in r88254. Ready for QA on Stage.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED

Comment 35

7 years ago
One thing seems to have been dropped; the three mobile add-ons no longer have a title. As per Comment 18 it should be "Mobile Starter Pack" I shouldn't have missed this - apologies for not alerting sooner.

Once that change is made, approved by me.
Reopening due to comment #35
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: FIXED → ---
(Assignee)

Comment 37

7 years ago
I've added back the title in r88262. I originally removed this thinking with only a single tab, the tab itself was no longer necessary.
Keywords: qawanted
qa-verified http://www-trunk.stage.mozilla.com/en-US/mobile/customize/
Keywords: qawanted
Merged to stage in r88266.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Keywords: push-needed
Resolution: --- → FIXED
(Reporter)

Comment 40

7 years ago
Thanks. Sorry for the delay with this.

1. Looks like the add-on names are missing. Also, the box looks a lot larger than it need to be. I can either add more add-ons or we should make it look like it fits
2. The copy says "favorite add-ons below" when they're actually to the side
3. The top of the page looks a bit wonky with the open space + the mobile banner is there a way we can move this CTA into the open space

Thanks!
Add-on links: locales are inconsistent. af, en-us and en-US
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 42

7 years ago
We need to remove the locales altogether - links should be:

Phony https://addons.mozilla.org/mobile/addon/phony/
Quit Firefox https://addons.mozilla.org/firefox/addon/quit-firefox/
Adblock Plus https://addons.mozilla.org/firefox/addon/adblock-plus/
Target Milestone: 2.3 → 2.4
(Assignee)

Comment 43

7 years ago
Cailin:
1. Titles are missing here as well: http://www.mozilla.com/en-US/firefox/customize/ Should they be added to both desktop and mobile?

2. updated

3. Is the go mobile box required on a page dedicated to mobile? We've removed the box and spaced out the links. Thoughts? r88491

4. r88485 - Add-on links have been changed from comment 6 and comment 21 to the ones listed in comment 42

5. To show two different themes, we added a second phone screenshot to add styles.
Target Milestone: 2.4 → 2.3
Caitlin, I know you're busy with the beta launch pending, but when you get a chance, can you look at Stephen's comments/questions in comment #43? Thanks.
(Reporter)

Comment 45

6 years ago
No worries. I don't see any questions. I see A but for #3 but just links to code, so I am not sure what I am commenting on.
Added titles to add-ons in trunk in r89363.

Merged the latest changes to stage in r89365.

James, that leaves the following merges from trunk->stage: r88254, r88266, and r89365.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Keywords: push-needed → qawanted
Resolution: --- → FIXED
qa-verified-trunk http://www-trunk.stage.mozilla.com/en-US/mobile/customize/
Keywords: qawanted
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.