Right click pop-up menu for address book does not work (context menu)

VERIFIED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
--
major
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Amrutha.S.Shenoy, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nab-menus)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (WinNT; I)
BuildID:    build id:2000122805

The Right click pop menu for anything in the Address book window say Address 
Book,Address Card and Address List does not work.

Reproducible: Always
Steps to Reproduce:
1.Start the browser.
2.Open the Address book.
3.Select either an Address Book,Address Card or Address list.
4.Right click on it.

Actual Results:  Does nothing,the right click pop up menu does not come up.

Expected Results:  The right click pop up menu with New Address Book,New Address 
List etc options should come up.

Comment 1

18 years ago
This is not implemented yet. I filed a similar bug yesterday about context menus
not being implemented in the Personal Toolbar. Confirming with build 20001229.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
reassigning to chuang.
Assignee: putterman → chuang
QA Contact: esther → pmock

Comment 3

18 years ago
Qa-assigned-to myself.
QA Contact: pmock → fenella

Updated

17 years ago
QA Contact: fenella → nbaca

Comment 4

17 years ago
*** Bug 101282 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: nbaca → olgam

Comment 5

17 years ago
*** Bug 108436 has been marked as a duplicate of this bug. ***
Summary: Right click pop-up menu for address book does not work. → Right click pop-up menu for address book does not work (context menu)

Updated

17 years ago
Whiteboard: nab-visual

Updated

17 years ago
Whiteboard: nab-visual → nab-menus

Comment 6

17 years ago
*** Bug 116114 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 124522 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Created attachment 68696 [details] [diff] [review]
patch

Comment 9

17 years ago
reassigning to racham.
Assignee: chuang → racham

Updated

16 years ago
Blocks: 158011

Updated

16 years ago
QA Contact: olgam → nbaca

Updated

16 years ago
OS: Windows NT → All
Hardware: PC → All
*** Bug 149696 has been marked as a duplicate of this bug. ***
mass re-assign.
Assignee: racham → sspitzer
(Assignee)

Comment 12

15 years ago
Taking from sspitzer@mozilla.org (Seth Spitzer)
Assignee: sspitzer → bugzilla
(Assignee)

Comment 13

15 years ago
Accepting
Status: NEW → ASSIGNED
(Assignee)

Comment 14

15 years ago
Created attachment 132767 [details] [diff] [review]
Patch v0.1 that implements context menus

This patch implements different context menus for the different panes:
Properties, New Card, New List and Delete for Address Book pane
Properties, Compose, IM and Delete for Results pane
(Assignee)

Updated

15 years ago
Attachment #68696 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #132767 - Flags: superreview?(sspitzer)
Attachment #132767 - Flags: review?(neil.parkwaycc.co.uk)

Comment 15

15 years ago
Comment on attachment 132767 [details] [diff] [review]
Patch v0.1 that implements context menus

>+    <command id="cmd_delete" oncommand="goDoCommand('button_delete');"/>
cmd_delete is wrong, that's reserved for Edit/Delete; as you're doing
goDoCommand('button_delete') use button_delete instead. In fact any commands
that use goDoCommand should be using the same id, this is so things like
goUpdateCommand work.

>+      <tree id="dirTree" context="DirTreeContext"
dirTreeContext, surely?

Also some accesskeys would be nice.
Attachment #132767 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Comment 16

15 years ago
Comment on attachment 132767 [details] [diff] [review]
Patch v0.1 that implements context menus

Cancelling old sr request
Attachment #132767 - Flags: superreview?(sspitzer)
(Assignee)

Comment 17

15 years ago
Created attachment 132795 [details] [diff] [review]
Patch v0.2 implements the context menus with accesskeys

Patch also other issues raised by Neil in comment#15
Attachment #132767 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #132795 - Flags: review?(neil.parkwaycc.co.uk)

Updated

15 years ago
Attachment #132795 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Updated

15 years ago
Attachment #132795 - Flags: superreview?(bienvenu)

Updated

15 years ago
Attachment #132795 - Flags: superreview?(bienvenu) → superreview+

Comment 18

15 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Verified FIXED with build 2004-06-06-09 on Windows XP.

Mailing lists, individual cards and address books themselves all have context
menus with accesskeys, too.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.