ISE - KeyError: '4.0'

VERIFIED FIXED in 3.4

Status

P3
minor
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: mbrandt, Assigned: davedash)

Tracking

Details

(Whiteboard: [stage][qa-], URL)

(Reporter)

Description

8 years ago
Traceback (most recent call last):

  File "/data/www/input.stage.mozilla.com/reporter/vendor/packages/Django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/input.stage.mozilla.com/reporter/apps/input/decorators.py", line 125, in negotiated
    return beta(request, *args, **kwargs)

  File "/data/www/input.stage.mozilla.com/reporter/apps/input/decorators.py", line 102, in wrapped
    return f(request, *args, **kwargs)

  File "/data/www/input.stage.mozilla.com/reporter/vendor/packages/Django/django/utils/decorators.py", line 76, in _wrapped_view
    response = view_func(request, *args, **kwargs)

  File "/data/www/input.stage.mozilla.com/reporter/apps/input/decorators.py", line 43, in cached_view
    return f(request, *args, **kwargs)

  File "/data/www/input.stage.mozilla.com/reporter/apps/dashboard/views.py", line 58, in beta
    plotBands=get_plotbands()

  File "/data/www/input.stage.mozilla.com/reporter/apps/search/views.py", line 39, in get_plotbands
    frm = unixtime(versions[version])

KeyError: '4.0'


<WSGIRequest
GET:<QueryDict: {}>,
POST:<QueryDict: {}>,
COOKIES:{'WT_FPC': 'id=63.245.220.240-399914960.30133615:lv=1299733296368:ss=1299732891514',
 'csrftoken': 'f0d3cdefa91c0df542e4be74f24dd48a',
 'intro_seen': 'true',
 's_vi': '',
 'wtspl': '602215'},
META:{'CSRF_COOKIE': 'f0d3cdefa91c0df542e4be74f24dd48a',
 'DOCUMENT_ROOT': '/data/www/input.stage.mozilla.com',
 'GATEWAY_INTERFACE': 'CGI/1.1',
 'HTTP_ACCEPT': 'text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8',
 'HTTP_ACCEPT_CHARSET': 'ISO-8859-1,utf-8;q=0.7,*;q=0.7',
 'HTTP_ACCEPT_ENCODING': 'gzip, deflate',
 'HTTP_ACCEPT_LANGUAGE': 'en-us,en;q=0.5',
 'HTTP_CONNECTION': 'keep-alive',
 'HTTP_COOKIE': 's_vi=[CS]v1|26A46D4805163AFD-600001820037051D[CE]; WT_FPC=id=63.245.220.240-399914960.30133615:lv=1299733296368:ss=1299732891514; csrftoken=f0d3cdefa91c0df542e4be74f24dd48a; wtspl=602215; intro_seen=true',
 'HTTP_HOST': 'input.stage.mozilla.com',
 'HTTP_KEEP_ALIVE': '115',
 'HTTP_USER_AGENT': 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12',
 'HTTP_X_CLUSTER_CLIENT_IP': '63.245.220.240',
 'HTTP_X_FORWARDED_FOR': '63.245.220.240',
 'HTTP_X_MOZ_PLATFORM': 'other',
 'PATH_INFO': u'/en-US/beta/',
 'PATH_TRANSLATED': '/data/www/input.stage.mozilla.com/reporter/wsgi/reporter.wsgi/en-US/beta/',
 'QUERY_STRING': '',
 'REMOTE_ADDR': '10.2.81.103',
 'REMOTE_PORT': '57379',
 'REQUEST_METHOD': 'GET',
 'REQUEST_URI': '/en-US/beta/',
 'SCRIPT_FILENAME': '/data/www/input.stage.mozilla.com/reporter/wsgi/reporter.wsgi',
 'SCRIPT_NAME': u'',
 'SERVER_ADDR': '10.2.81.29',
 'SERVER_ADMIN': 'webmaster@mozilla.com',
 'SERVER_NAME': 'input.stage.mozilla.com',
 'SERVER_PORT': '80',
 'SERVER_PROTOCOL': 'HTTP/1.1',
 'SERVER_SIGNATURE': '<address>Apache/2.2.3 (Red Hat) Server at input.stage.mozilla.com Port 80</address>\n',
 'SERVER_SOFTWARE': 'Apache/2.2.3 (Red Hat)',
 'mod_wsgi.application_group': 'input.stage.mozilla.com|',
 'mod_wsgi.callable_object': 'application',
 'mod_wsgi.handler_script': '',
 'mod_wsgi.input_chunked': '0',
 'mod_wsgi.listener_host': '',
 'mod_wsgi.listener_port': '80',
 'mod_wsgi.process_group': '',
 'mod_wsgi.request_handler': 'wsgi-script',
 'mod_wsgi.script_reloading': '1',
 'mod_wsgi.version': (3, 2),
 'wsgi.errors': <mod_wsgi.Log object at 0xb0f9db8>,
 'wsgi.file_wrapper': <built-in method file_wrapper of mod_wsgi.Adapter object at 0xa4bb608>,
 'wsgi.input': <mod_wsgi.Input object at 0xb0f9de0>,
 'wsgi.loaded': datetime.datetime(2011, 3, 9, 13, 14, 43, 216652),
 'wsgi.multiprocess': True,
 'wsgi.multithread': False,
 'wsgi.run_once': False,
 'wsgi.url_scheme': 'http',
 'wsgi.version': (1, 1)}>
Dave, can you take a look please? The 4.0rc1 change in product details has resulted in this being messed up. You might just want to account for the case when a version is not in the list of release dates here, and (obviously) not show a plot band for it.
Assignee: nobody → dd
Severity: normal → major
Target Milestone: --- → 3.3
(Reporter)

Updated

8 years ago
Duplicate of this bug: 640306

Updated

8 years ago
Target Milestone: 3.3 → 3.4
Lowering to minor/P3 because the immediate problem is fixed, now it's just a robustness issue for the future.
Severity: major → minor
Priority: -- → P3

Updated

8 years ago
Whiteboard: [stage] → [stage][3.5]

Updated

8 years ago
Target Milestone: 3.4 → 3.5

Updated

8 years ago
Whiteboard: [stage][3.5] → [stage]
Slipping this in, it doesn't fix anything, but it might prevent a calamity.

http://github.com/fwenzel/reporter/commit/a916725
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [stage] → [stage][qa-]
Target Milestone: 3.5 → 3.4
(Reporter)

Comment 5

8 years ago
Thanks Dave :-)
(Reporter)

Comment 6

8 years ago
Verified as [qa-]
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.