autowhitelisting on @lists.mozilla.org lists for list members of any list is broken

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
critical
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: justdave, Assigned: justdave)

Tracking

Details

The same script that generates the global whitelist on lists.mozilla.org that allows subscribers of any list to post to any of them is supposed to also include the membership of all of the @bugzilla.org lists, because of a couple of them also being cross-gatewayed to newsgroups.  This appears to be broken, as members of developers@bugzilla.org (which is cross-gatewayed to dev-apps-bugzilla@lists.mozilla.org) are getting "reject" notices from dev-apps-bugzilla.
Assignee: server-ops → justdave

Comment 1

7 years ago
However, note that my messages aren't actually getting rejected, I just get the reject notices.

Comment 2

7 years ago
Oh, okay. My messages aren't making it to the newsgroup, but they are making it to the mailing list.
I think this entire thing is broken in general (and I'm surprised I haven't heard more noise about it).  I just got a reject trying to post to dev-planning (which I'm not a member of) even though I am a member of several other lists on lists.mozilla.org.
Summary: autowhitelisting on @lists.mozilla.org lists for @bugzilla.org lists members is broken → autowhitelisting on @lists.mozilla.org lists for list members of any list is broken
Duplicate of this bug: 648030
The unfortunate timing with the Firefox 4 release (desktop and mobile) plus the AllHands event at Mozilla Mon/Tue this week conspired to prevent time to work on this.  Back in catchup mode now, and this is one of the more annoying things on my list so it should be taken care of shortly.
Severity: minor → critical
OK, I think this is fixed now.  The whitelist was overriding "hold" but it wasn't overriding "reject" or "discard".  If anyone finds this still happening please reopen.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.