All users were logged out of Bugzilla on October 13th, 2018

table cell widths crazy when window is large

VERIFIED FIXED in M7

Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: dbaron, Assigned: karnaze)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

When the window I dispay the document in is close to maximized size, the table
cell on the left side of the above URL is way too thin, so only the bullets of
the topmost list show up.  Most of the navigation cell disappears.

If you aren't seeing this, I can send you a screenshot/more info.

Comment 1

20 years ago
Yes, I see this too. (I had noticed a similar problem on mozilla.org yesterday).

I believe that this is not a new problem in the tables code; rather, mozilla.org
has changed something in their template that now triggers a known bug. That
known bug is bug #1302 ("over-specified colspans") but I haven't fully
convinced myself that this bug and 1302 are truly one and the same (will look
some more).

[I suppose in the interim, if/when I do confirm this, it would be good idea to
get mozilla.org's template modified to avoid this bug. Who is the point person
for the website?]

Comment 2

20 years ago
Created attachment 188 [details]
testcase; width distribution to colspan columns

Comment 3

20 years ago
So, it is not the _same_ bug as bug 1302, but it is COLSPAN related.
It just seems to be a problem with distributing auto width to COLSPAN'd
columns. (At least the test case shows this. I couldn't really find a
way to 'patch' the mozilla.org page).

Comment 4

20 years ago
*** Bug 6951 has been marked as a duplicate of this bug. ***

Comment 5

20 years ago
*** Bug 6969 has been marked as a duplicate of this bug. ***

Comment 6

20 years ago
See also bug #6634 and bug #6697 which may (or may not) be related to this
problem. (These bugs reference on X-window painting bug when scrolling right
but occur (recently) on http://www.mozilla.org/quality/smoketests/).
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
Target Milestone: M7
(Assignee)

Comment 7

20 years ago
fixed with latest checkin.

Comment 8

20 years ago
*** Bug 7219 has been marked as a duplicate of this bug. ***

Comment 9

20 years ago
*** Bug 7390 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 10

20 years ago
Using 6/3 build, verified bug fixed.
You need to log in before you can comment on or make changes to this bug.