assignment to history.pushState is reverted at a strange time

RESOLVED DUPLICATE of bug 593910

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 593910
7 years ago
7 years ago

People

(Reporter: Glenn Maynard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Assigning window.history.pushState = null is allowed, but reverts to the original method later, with no obvious trigger.

At http://zewt.org/~glenn/test-ff4rc1-pushState-assignment.html, "null" is logged immediately, after onload and after one second, but after five seconds the original method is back.

[20:01:36.137] 1 null
[20:01:36.147] 2 null
[20:01:37.138] 3 null
[20:01:41.138] 4 function pushState() {[native code]}

(Encountered while working around #640387.)


Reproducible: Always
We don't preserve history objects with expandos on them, so I would expect that it gets GCed and you get a new history object....
Is this a dupe of bug 593910?
Yes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 593910
You need to log in before you can comment on or make changes to this bug.