App is unable to perform a restart after a language is changed or an addon is added

RESOLVED DUPLICATE of bug 640190

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 640190
7 years ago
7 years ago

People

(Reporter: xti, Unassigned)

Tracking

Trunk
ARM
Android

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Build Identifier: 

When a language is changed or an addon is installed, when Restart button is tapped, the app just close and doesn't return back.

Reproducible: Always

Steps to Reproduce:
1. Open Fennec App
2. Tap on Settings button > Preferences
3. Change the language
4. Tap on Restart button from the pop up message
5. Tap on Settings button > Add-ons
6. Add Home Links addon
7. Tap on Restart button from the pop up message


Actual Results:  
After steps 4 and 7 the app exits, but doesn't reopen again. It seems that it tries to reopen, because the screen changes its state to black and then to white. This happens for a very short moment and after that the app crashes.

Expected Results:  
The language is changed corectly and the addon is installed properly. The app restarts normaly.

This issue is reproducing always on Sony Ericsson Xperia X10 - Android 2.1-update1

Build id : Mozilla/5.0 (Maemo;Linux armv7l;rv:2.0b13pre)Gecko/20110308
Firefox/4.0b13pre Fennec /4.0b6pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1
(Reporter)

Updated

7 years ago
OS: Other → Android
Hardware: Other → ARM
(Reporter)

Comment 1

7 years ago
Created attachment 518309 [details]
Restart crash log
(Reporter)

Updated

7 years ago
Attachment #518309 - Attachment description: Unable to perform a restart → Restart crash log
dupe of bug 640068 and bug 640190
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 640190
You need to log in before you can comment on or make changes to this bug.