[regression][rc1] WebGL fails; canvas.getContext("experimental-webgl") does not return anything

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: aldo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

On RC1, WebGL fails to initialise. canvas.getContext("experimental-webgl") simply does not return any value. Content that worked fine on beta 12 (and still work in other browsers supporting webgl, such as chrome 9+) no longer works in rc1.

Reinstalling beta 12 fixes the problem.

Reproducible: Always

Steps to Reproduce:
1. create a document with a canvas
2. document.getElementById("canvas").getContext("experimental-webgl")

Actual Results:  
nothing is returned

Expected Results:  
a webgl context is returned

More repro sites:
http://fieldofview.github.com/PTViewerNG/
http://spidergl.org/example.php?id=13
(Reporter)

Comment 1

7 years ago
Upon further testing, I see the following:

* When getting canvasObj.getContext("experimental-webgl") after a page has fully loaded, no value is returned. 
* Getting canvasObj.getContext("2d") results in the proper 2d context.
* Subsequent getting of canvasObj.getContext("experimental-webgl") returns 'null', but only after getting the 2d context first.
(Reporter)

Comment 2

7 years ago
After setting webgl.prefer-native-gl to true, succesfuly testing a repro site, and reverting webgl.prefer-native-gl back to the default false, I can no longer reproduce the issue. Strange. Fluke?
Component: General → Canvas: WebGL
Product: Firefox → Core
QA Contact: general → canvas.webgl
Strange indeed. If you ever can reproduce again, the most useful thing to do would be to use the archived nightly builds,

    http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/

to see on what day it regressed.
(Reporter)

Comment 4

7 years ago
I have updated another machine that had never seen a FX4 beta before, first to FX4 b12, and then to FX4 rc1, and webgl worked in both versions. The only thing I can think of is that on the machine that exhibited the bug there was some remnant setting of an earlier beta, which has now been cleared out. Or something.

I'm keeping my eye out for a way to repro, untill then this issue is "unable to reproduce".
OK. So I mark this bug as "Works for me", and feel free to reopen it when you can reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.