Remnants of icon bar remain in location bar after changing tabs with new URL



Camino Graveyard
Location Bar & Autocomplete
7 years ago
3 years ago


(Reporter: ss, Unassigned)





(2 attachments)



7 years ago
Created attachment 518332 [details]

(We aren't calling it the "icon bar" are we? What are we calling it?)

1. Go to a site with SSL (and RSS, preferably) like
2. Open a new tab
3. Type "" or any other URL
4. Switch back to your SSL/RSS tab using your keyboard

A nice looking location bar.

Remnants remain from the icon bar.

Note that if you type a URL into tab 1 (that is, the tab with SSL/RSS), the icon bar stays until the new site loads.
I don't see anything untoward in your screenshot, nor when I follow your steps.  I don't understand this bug at all.

(I think, if anything, we're calling it the icon partition in the location bar.)

Comment 2

7 years ago
Zoom in a bunch. Note that there's an extra one pixel border around where the icon partition used to be (excluding the left side).

Comment 3

7 years ago
(Also, I'm using 2.1a1... in case things changed.)

Comment 4

7 years ago
So if I understand correctly, the icon partition just disappeared when you switched back to the https tab? They just leave a faint line - mostly visible at the top & bottom of where the left edge of the partition should be [*]

I don't think I've ever seen that.

[*] I had to use pixie to find it…
Created attachment 518585 [details]
Remnants, as seen in Pixie

Yes, comment 4 is what's happening.  Sam made condescending comments about my "old eyes", but I replied chastising his inadequate initial description and lack of Pixie-produced screenshot :P

I can see it if I look very carefully now that I know what I'm looking for, but not otherwise ;)


3 years ago
OS: All → Mac OS X
You need to log in before you can comment on or make changes to this bug.