The Rebuild button in the self-serve page needs a better UI

RESOLVED DUPLICATE of bug 636027

Status

Release Engineering
General
RESOLVED DUPLICATE of bug 636027
7 years ago
4 years ago

People

(Reporter: Away for a while, Unassigned)

Tracking

({buildapi})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Currently this button redirects you to another page, and going back to the original page doesn't keep the state of the controls on the page.  For example, if you're on page 8 of the builds for a revision, you need to manually click the Next button to go to the page 8 to continue from where you left off.  I think it's best for the Rebuild button to not redirect, and just show the result of the Rebuild request somewhere on the page.

Comment 1

7 years ago
dup of bug 627566?

I would also hazard a guess that all the self-serve whiteboard items[1] can be duped against Catlee's original statement that "Really, the goal here wasn’t to create a fully functional web interface, but rather to provide a functional programmatic interface." [2]

[1] https://bugzilla.mozilla.org/buglist.cgi?resolution=DUPLICATE;resolution=---;status_whiteboard_type=allwordssubstr;query_format=advanced;status_whiteboard=[self-serve];component=Release%20Engineering;component=Release%20Engineering%3A%20Custom%20Builds;component=Release%20Engineering%3A%20Future;product=mozilla.org
[2] http://atlee.ca/blog/2011/02/17/self-serve-builds/

I'll leave this open, however, in case it's not a dup of bug 627566.
Whiteboard: [self-serve]
DUPE of bug 636027 or bug 627566.

Patches welcome to fix up the UI, but I'm not going to be putting much time into it in the next month or so.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 636027

Updated

5 years ago
Keywords: buildapi
Whiteboard: [self-serve]
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.