Backspace on table Column headers having DIV with contenteditable clears headers of all columns

RESOLVED DUPLICATE of bug 414526

Status

()

--
major
RESOLVED DUPLICATE of bug 414526
8 years ago
8 years ago

People

(Reporter: vasanthg, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.699.0 Safari/534.24
Build Identifier: FireFox 4.0 RC1

Create a table with 4 columns having headers in <div> and contenteditable true.Now place the cursor at the beginning of the third column and press backspace.The header of the previous column gets deleted.In case there are any <div> with contenteditable true before the table,those contents also get deleted on further backspace.

Reproducible: Always

Steps to Reproduce:
1.Create a HTM page with following contents

<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html>
<head>
	<title>Test</title>
	<script type="text/javascript">
	</script>
</head>
<body>
	<div id="editContent" contenteditable>Enter Value</div>
	<table border="1" style="width:80%">
		<thead>
			<tr>
				<th><div contenteditable style="height: 100%; width: 100%;">heading1</div></th>
				<th><div contenteditable style="height: 100%; width: 100%;">heading2</div></th>
				<th><div contenteditable style="height: 100%; width: 100%;">heading3</div></th>
				<th><div contenteditable style="height: 100%; width: 100%;">heading4</div></th>
			</tr>
		</thead>
		<tbody>
			<tr>
				<td><div contenteditable style="height: 100%; width: 100%;">row 1, column 1 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 1, column 2 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 1, column 3 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 1, column 4 text.</div></td>
			</tr>
			<tr>
				<td><div contenteditable style="height: 100%; width: 100%;">row 2, column 1 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 2, column 2 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 2, column 3 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 2, column 4 text.</div></td>
			</tr>
			<tr>
				<td><div contenteditable style="height: 100%; width: 100%;">row 3, column 1 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 3, column 2 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 3, column 3 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 3, column 4 text.</div></td>
			</tr>
			<tr>
				<td><div contenteditable style="height: 100%; width: 100%;">row 4, column 1 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 4, column 2 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 4, column 3 text.</div></td>
				<td><div contenteditable style="height: 100%; width: 100%;">row 4, column 4 text.</div></td>
			</tr>
		</tbody>
	</table>
</body>
</html>

2.Now Open the page in Firefox 3.6 or Firefox 4 RC1.
3.Place the cursor just before 'heading4' and press backspace.
Actual Results:  
The content of the previous column header also get deleted.On further backspace the content of div with ID 'editContent' also gets deleted.

Expected Results:  
The content of the previous column header should not get deleted.

It's working fine in Chrome 10,Chrome 11,IE8 and IE9. But fails in Firefox 3.6 and Firefox 4 RC1.
(Reporter)

Comment 1

8 years ago
Created attachment 518687 [details]
Firefox backspace on DIV with content editable

Comment 2

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110310 Firefox/4.0b13pre

Confirmed. Placing the cursor before Heading 4 and pressing backspace, previous colur headers gets deleted.
(Reporter)

Updated

8 years ago
Severity: normal → major
Component: General → Editor
Keywords: testcase
Product: Firefox → Core
QA Contact: general → editor
Version: unspecified → Trunk

Updated

8 years ago
Whiteboard: DUPEME?
Confirmed.

This issue is reproducible on :

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

and 

Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Confirmed on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110314 Firefox/4.0b13pre
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME?
Duplicate of bug: 414526
You need to log in before you can comment on or make changes to this bug.