If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pinned tabs are lost (forgotten) when Firefox is restarted.

RESOLVED DUPLICATE of bug 587400

Status

()

Firefox
Session Restore
--
major
RESOLVED DUPLICATE of bug 587400
7 years ago
6 years ago

People

(Reporter: c711970@rmqkr.net, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4rc])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

When fully closing Firefox, and reopening, pinned tabs are no longer present. This occurs when a new window is opened, that does not contain pinned tabs, and this window is closed after the window containing the pinned tabs.

Reproducible: Always

Steps to Reproduce:
1. Ensure all instances of Firefox are closed.
2. Open a new window. Open a few tabs on varying websites and pin the tabs by right clicking on the tab and pressing 'Pin as tab'.
3. Open a second window.
4. Close the window from Step 2 (Window containing tabs).
5. Close the window from step 3 (Window with no tabs).
6. Reopen Firefox and observe that pinned tabs are not saved.
Actual Results:  
Pinned tabs are not present.

Expected Results:  
Pinned tabs should appear whenever Firefox is freshly opened.

For interest, issue also present in chromium. See http://code.google.com/p/chromium/issues/detail?id=40293 .
Confirmed with Firefox 4.0rc1 on Windows 7.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Also happens on Mac and Linux. I'm wondering if session store is saving the session seeing only the last opened window (ie. since the first window has been closed, it forgets about it -- intentionally).
OS: Windows 7 → All
Hardware: x86_64 → All
Whiteboard: [4rc]

Comment 3

6 years ago
Happens on windows xp pro
firefox version 6.0 for me

Comment 4

6 years ago
(In reply to subwayfox from comment #3)
> Happens on windows xp pro
> firefox version 6.0 for me
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> Also happens on Mac and Linux. I'm wondering if session store is saving the
> session seeing only the last opened window (ie. since the first window has
> been closed, it forgets about it -- intentionally).

That is what happens. We helped alleviate it a bit with bug 625016, but we do need to make it better still. Hopefully global app tabs will fix everything.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587400
You need to log in before you can comment on or make changes to this bug.