Poor modal interaction when Password Prompt comes up when Save Image As dialog is already up

RESOLVED DUPLICATE of bug 476541

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 476541
7 years ago
5 years ago

People

(Reporter: Tom Tyler, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

I was saving an image from the noted URL (I don't think there's anything wrong with that web site).  I right-clicked the image and clicked "Save Image As ...", and it brought up the dialog to select a location to save the file.  In the midst of finding a location to save the file, the password prompt dialog popped up.  This is the popup that usually comes up the first time Firefox wants to access a saved password to autofill a password on a web site.  (There was nothing on the indicated web site, but there may have been on another tab.)

Once the dialog popup up, there was some sort of MODAL interaction issue.  The "Save" and "Cancel" buttons on the file save dialog that I had up did not close the dialog; in fact they did nothing except change shading to indicate a detected button push.  I then tried to click on the password dialog to complete entering the prompted-for password, but mouse clicking did not change the input focus away from the save file dialog -- it was stuck in the file name input box of the file saving dialog.  So I was stuck -- I couldn't complete either the entry of the password, or save or cancel the file save operation.

My fix was to do a Force Quit on Firefox and restart.

I suspect somewhere in here there's a MODAL mode set on a popup that might need to be reconsidered, perhaps the file saving dialog or perhaps the password prompting dialog.

I hope this helps!

Cheers!

Tom

Reproducible: Sometimes

Steps to Reproduce:
This is tricky to reproduce.

1. Make sure FireFox is quit, and not running.

2. Start Firefox.  Bring up a few tabs, with one of them being a site that for which Firefox would normally autofill the password.  Do NOT start data entry, as that will popup the password prompt dialog immediately, and we don't want that to reproduce.  If that popup comes up, quit FireFox and start over.

3. Wander to a different tab one with a graphic.  Select the image and do "Save Image As ..."

4. On the Save Image As dialog, waste some time.  Spend a few minutes navigating trying to figure out what to save your file.  At some point, the password prompt might come up.  When it does, see if you're in the "stuck" situation as described above, where the Save and Cancel buttons do nothing and you can't change the input focus.  If that happens, you've successfully reproduced the condition I'm reporting. :)

When you go to an input field that requires autofill, you'll immediately be prompted to enter your password.  The trick to reproduce this is to just open a page that contains such an input field, but don't go near it, and then go to another tab and get the Save File As dialog to come up, then wait...
Actual Results:  
When the condition occurs, the user is stuck.

Expected Results:  
Desired result would be for the password prompt to either not be modal *or* be model, but only come up if you're on the tab that contains and input field, and then only if no other dialogs are already up.

Great product!  Keep up the good work.

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 1

6 years ago
Duplicates: bug 476541.

Just ran into this, but with the Save Link As… app-modal window rather than Save Image As…. The problem was triggered by the Master Password modal dialog appearing while the Save app-modal window was still open.

Build id: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120502 Firefox/14.0a2

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.