Products containing spaces won't show any bugs while browsing on RH5. Spaces appear as %20

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Tiago Ferreira, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: Bugzila 4.0

If a product is created with spaces eg "Product 1", then after creating bugs, when browsing the product no bugs are shown.
If i perform an equivalent search, then all the rights bugs appear.

Reproducible: Always

Steps to Reproduce:
1.Create a product "product 1"
2.Create a componente "component"
3.Create a bug um product "product 1" and "component"
4.Click browse and select "product 1" and "component" 
Actual Results:  
No bugs are founds

Expected Results:  
A bug list containing the created bug

Comment 1

7 years ago
The list of bugs is correctly displayed. Note that the list of bugs displayed from the "Browse" page only displays open bugs, not closed ones.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

7 years ago
The problem occurs, although it may an incompatibility with the RH5 version being used. Also, the problem is related to bad http character escaping.
Please have a look at the 2 pictures:
http://tiagoferreira.nome.pt/publish/bugzilla/browse.png
http://tiagoferreira.nome.pt/publish/bugzilla/search.png
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

7 years ago
Well, in comment 0, you said the component name is "component", but you use TestComponent in your search. No wonder you get 0 bugs. IMO, this is not a real bug, but a support question.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

7 years ago
Have a look at the product name, please.
Do you think it is the expected behaviour?
(Reporter)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
i'm unable to reproduce this with bugzilla 3.6, 4.0 vanilla or 4.0 bmo.

the only thing i can think of is the bugs returned by your search aren't in the TestComponent component.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

7 years ago
on the browse.png picture you can see that the product is "test%20product" instead of "test product", which is causing the problem.

On the Search picture, you can see that the product is actually named "test product".

Now, this may be a problem regarding the RH5, but I don't know where to start debugging.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: Products containing spaces won't show any bugs while browsing → Products containing spaces won't show any bugs while browsing on RH5. Spaces appear as %20
sorry, but this looks like a support issue; we're unable to reproduce this problem, so really looks like this isn't a bug within bugzilla itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
i chatted with tiago on irc.  apache was configured to do a http-->https redirect (with mod_rewrite), which was resulting in a double encoding of urls.

so the requests were:

https://example.com/buglist.cgi?product=Test%20Product&component=TestComponent&resolution=--- [HTTP/1.1 302 Found 1892ms]
http://example.com/buglist.cgi?product=Test%20Product&component=TestComponent&resolution=---&list_id=145 [HTTP/1.1 302 Found 816ms]
https://example.com/buglist.cgi?product=Test%2520Product&component=TestComponent&resolution=---&list_id=145 [HTTP/1.1 200 OK 3082ms]

once the mod_rewrite rule was disabled, bugzilla started functioning correctly.
You need to log in before you can comment on or make changes to this bug.