If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dragging and dropping bookmark from 'Library' search page copies instead of moving

RESOLVED DUPLICATE of bug 543314

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 543314
7 years ago
7 years ago

People

(Reporter: AndiDog, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110311 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110311 Firefox/4.0b13pre

 

Reproducible: Always

Steps to Reproduce:
1. Open the bookmarks library (Ctrl+Shift+B)
2. Search for some bookmarks
3. Drag a bookmark to a folder on the left pane
Actual Results:  
The cursor shows the copy icon, and Minefield actually duplicates the bookmark in the target directory.

Expected Results:  
Nobody wants duplicate bookmarks. The only reason one would drag/drop bookmarks is to categorize them, so the operation should be a move, not a copy.
Searches are read-only by design, since a search can return bookmarks from different folders and we don't print out the containing folder, right now you would not know where the bookmark was moved from. Also some bookmark search (tags for example) is showing something that is more like a metadata then the real bookmark. So a copy operation is forced on each search.
(Reporter)

Comment 2

7 years ago
Do you think people really care where bookmarks are moved *from*? I'd rather say it's only important where they are moved *to*, namely the folder/category in which the bookmark belongs.

As I said before, I don't see any point in duplicating bookmarks at all. Especially if I do a search in my unsorted bookmarks - in that case, I am sure where the bookmarks are moved from, because clicking on "Search in: <Unsorted Bookmarks>" will only show bookmarks from there.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543314
You need to log in before you can comment on or make changes to this bug.