opening or reloading about:addons displays "Ci is not defined" error in the error console

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Juan Manuel Rodriguez Alvardo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Triaged 14/02/12 - no longer reproducable?])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Every time I open or reload about:addons page, I get the next error in the error console:

Error: Ci is not defined
Source File: chrome://mozapps/content/extensions/extensions.js
Line: 1794

Reproducible: Always

Steps to Reproduce:
1.open about:addons
2.reload it
Actual Results:  
This error is displayed in the error console:

Error: Ci is not defined
Source File: chrome://mozapps/content/extensions/extensions.js
Line: 1794

Comment 1

7 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile

Does the issue occur with the latest nightly? http://nightly.mozilla.org/

WFM - Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre ID:20110303122446
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Does the issue still occur if you start Firefox in Safe Mode?
> http://support.mozilla.com/en-US/kb/Safe+Mode
> 
YES
> How about with a new, empty profile?
> http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
> 
YES
> Does the issue occur with the latest nightly? http://nightly.mozilla.org/
> 
> WFM - Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110303
> Firefox/4.0b13pre ID:20110303122446
YES

Hope that helps
This is in gDiscoverView.onStateChange()...

http://mxr.mozilla.org/mozilla2.0/source/toolkit/mozapps/extensions/content/extensions.js#1794

Though offhand I don't see how this would happen, |Ci| is globally defined here.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
This sounds very familiar... not sure if its a dupe of a bug I can't find, or something similar that's been fixed in the past. Anyway, it can happen when closing the addons manager while there's a request in progress for the Get Add-ons pane. The listener still gets called, but its scope has disappeared. No idea how that could happen when *opening* the addons manager... though the steps to reproduce suggest reloading is necessary, which could definitely trigger it.
Whiteboard: [dupe?]
We have a bug an automated test which spins the exact same error message. Not sure if this bug is related. Right now I even can't find it. I'm sure Dave knows the bug number.

Comment 6

7 years ago
(In reply to comment #5)
> We have a bug an automated test which spins the exact same error message. Not
> sure if this bug is related. Right now I even can't find it. I'm sure Dave
> knows the bug number.

Apparently not!
https://bugzilla.mozilla.org/show_bug.cgi?id=640519#c10
Hm, just noticed I get this every time I reload about:addons, regardless of whether the Get Addons pane is loading or not. That's... new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 665322

Updated

6 years ago
Duplicate of this bug: 634105
I can't seem to be able to reproduce this now. Unless someone can report it's still reproducible, I'll close this bug in a week or so.
Whiteboard: [dupe?] → [Triaged 14/02/12 - no longer reproducable?]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.