context/right-click menu "Search Google for" broken in popup windows, displays assertion failed dialog, And Firefox should open the new tab in a full browser window

VERIFIED FIXED in Firefox 5

Status

()

Firefox
Search
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Steffen Wilberg, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 5
regression
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4rc])

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110311 Firefox/4.0b13pre

The context menu "Search Google for" is broken in popup windows.

STR:
1. Open a popup without navigation toolbar and tab bar:
In the error console, evaluate this:
window.open("http://www.mozilla.org", "", "location=no")
2. In the popup window, select any text, right-click, and select "Search Google for" in the context menu.

Expected result: new tab opened either in the popup window (like in 3.6) or the main window.

Actual results:
1. Nothing.
2. When you close the supposedly single tab in the popup by pressing Ctrl+w, there's your search tab, hidden behind the one you just closed.
After a second or two, an alert dialog opens:
Assertion Failed
ASSERT: Giving up waiting for the tab closing animation to finish (bug 608589) Stack Trace: 0:([object XULElement],[object XULElement],0)
3. After closing that dialog, interacting with the search results page is broken in strange ways and throws several errors.
(Reporter)

Comment 1

7 years ago
Created attachment 518816 [details]
testcase

Instead of step 1, open the testcase and click the link to open the popup.
Then proceed with step 2.
(Reporter)

Comment 2

7 years ago
Being a release build, Firefox 4.0rc1 doesn't display the Assertion Failed dialog and reports to the error console instead.

Comment 3

7 years ago
And a hidden tab is created after doing search select.
Firefox should open the new tab in a full browser window.

I think this should block 2.0
Summary: context/right-click menu "Search Google for" broken in popup windows, displays assertion failed dialog → context/right-click menu "Search Google for" broken in popup windows, displays assertion failed dialog, And Firefox should open the new tab in a full browser window
(Assignee)

Updated

7 years ago
No longer blocks: 608589
(Assignee)

Updated

7 years ago
Assignee: nobody → dao
(Assignee)

Comment 4

7 years ago
Created attachment 518891 [details] [diff] [review]
patch

I've also filed bug 641157
Attachment #518891 - Flags: review?(gavin.sharp)
Whiteboard: [4rc]
(Assignee)

Updated

7 years ago
Attachment #518891 - Flags: review?(dolske)
Attachment #518891 - Flags: review?(gavin.sharp)
Attachment #518891 - Flags: review?(dolske)
Attachment #518891 - Flags: review+
Though this makes us obey the browser.tabs.loadBookmarksInBackground pref where we wouldn't before, which I think may be problematic. Maybe this should depend on the aInBackground changes from bug 610203's patch...
(Assignee)

Comment 6

7 years ago
Nope, this uses browser.tabs.loadInBackground just like gBrowser.loadOneTab.

Updated

7 years ago
Duplicate of this bug: 642585
(In reply to comment #6)
> Nope, this uses browser.tabs.loadInBackground just like gBrowser.loadOneTab.

Oh, I missed that loadOneTab checks the pref. It checks browser.tabs.loadInBackground, though, whereas with that patch won't we end up using browser.tabs.loadBookmarksInBackground (aFromChrome is true via openLinkIn)...
(Assignee)

Comment 9

7 years ago
(In reply to comment #8)
> Oh, I missed that loadOneTab checks the pref. It checks
> browser.tabs.loadInBackground, though, whereas with that patch won't we end up
> using browser.tabs.loadBookmarksInBackground (aFromChrome is true via
> openLinkIn)...

openUILinkIn sets fromChrome, openLinkIn doesn't.
Quite true. I misread the patch. I hate it when I do that.
OS: Windows 7 → Windows XP
(Assignee)

Comment 11

7 years ago
http://hg.mozilla.org/projects/cedar/rev/dced24264c95
Whiteboard: [4rc] → [4rc] fixed-in-cedar

Comment 12

7 years ago
http://hg.mozilla.org/mozilla-central/rev/dced24264c95
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: [4rc] fixed-in-cedar → [4rc]
(Assignee)

Updated

7 years ago
Target Milestone: --- → Firefox4.2
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) Gecko/20110326 Firefox/4.2a1pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
OS: Windows XP → All
Hardware: x86 → All

Comment 14

7 years ago
Verified fixed on Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre
(Assignee)

Updated

7 years ago
Target Milestone: Firefox5 → Firefox 5
You need to log in before you can comment on or make changes to this bug.