realplayer download this view triggers a crash at [@ msvcr90.dll@0x25e45 ] with firefox 4 and windows media player plugin

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: chofmann, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

probably should go over to plugins | realplayer

small number of these seen with the last few betas, but a lot higher
ramp up in crashes with seem to be happening with this signature as 4.0 RC scales up.

date     crashes at
         msvcr90.dll@0x25e45

20110305 0
20110306 0
20110307 4
20110308 5
20110309 11
20110310 48

         30 more report up until mid-day today..

All reports seem to show rpmainbrowserrecordplugin.dll version  12.0.1.633

stack looks like

https://crash-stats.mozilla.com/report/index/7efb57ff-e782-4d85-aba6-4bab42110311

Frame 	Module 	Signature [Expand] 	Source
0 	msvcr90.dll 	msvcr90.dll@0x25e45 	
1 	msvcr90.dll 	msvcr90.dll@0x25ea8 	
2 	msvcr90.dll 	msvcr90.dll@0x25ef4 	
3 	rpnpshimwmp.dll 	rpnpshimwmp.dll@0x3a2d 	
4 	xul.dll 	mozilla::PluginPRLibrary::NP_GetEntryPoints 	modules/plugin/base/src/PluginPRLibrary.cpp:171
5 	xul.dll 	nsNPAPIPlugin::CreatePlugin 	modules/plugin/base/src/nsNPAPIPlugin.cpp:517
6 	xul.dll 	CreateNPAPIPlugin 	modules/plugin/base/src/nsPluginHost.cpp:1789
7 	xul.dll 	nsPluginHost::EnsurePluginLoaded 	modules/plugin/base/src/nsPluginHost.cpp:1806
8 	xul.dll 	nsPluginHost::GetPlugin 	modules/plugin/base/src/nsPluginHost.cpp:1838
9 	xul.dll 	nsPluginHost::TrySetUpPluginInstance 	modules/plugin/base/src/nsPluginHost.cpp:1340
10 	xul.dll 	nsPluginHost::SetUpPluginInstance 	modules/plugin/base/src/nsPluginHost.cpp:1264

more reports at  
https://crash-stats.mozilla.com/report/list?signature=msvcr90.dll%400x25e45

checking --- msvcr90.dll@0x25e45 20110310-crashdata.csv
found in: 4.0 4.0b12
release total-crashes
              msvcr90.dll@0x25e45 crashes
                         pct.
all     370362  48      0.000129603
4.0     32055   43      0.00134144
4.0b12  62897   5       7.9495e-05

os breakdown
msvcr90.dll@0x25e45Total 48
Win5.1  0.00
Win6.0  0.00
Win6.1  1.00

Correlation to startup or time of session
48 total crashes for msvcr90.dll@0x25e45 on 20110310-crashdata.csv
33 startup crashes inside 30 sec.
43 startup crashes inside 3 min.
OS: Mac OS X → Windows 7
Yeah, this appears to be a bug in the realplayer shim where even loading the plugin at all will crash. Is it associated with particular versions of rpnpshimwmp.dll?
in most reports rpnpshimwmp.dll doesn't have any version info. 

here is a breakdown of the version info or debug id where no version is available for the 58 reports we got yesterday.

   1 12.0.1.599
   1 12.0.1.633
  26 AEF01CCB25014EDE93AFF7EBBCBDA8C5c
  30 D36D7EC77E174460BFA181B733488BC8c
So, I kept wondering about this bug because i have no trouble w/ youtube and using realplayer's download this video feature, then i realized that youtube is flash and thus it's a different shim.

fwiw, I have:
14.0.2 RealPlayer Browser Record Plugin {ABDE892B-13A8-4d1b-88E6-365A6E755758}
12.0.1.633 rpnpshimqt.dll
12.0.1.633 rpnpshimrp.dll
12.0.1.633 rpnpshimswf.dll
12.0.1.633 rpnpshimwmp.dll

i tried installing the WMP plugin using plugin downloader (which seems to give me something from 2007?) but i couldn't convince the two pages i tried to give me a real downloader link.
Summary: realplayer? crash at [@ msvcr90.dll@0x25e45 ] with firefox 4. → realplayer download this view triggers a crash at [@ msvcr90.dll@0x25e45 ] with firefox 4 and windows media player plugin
I've been playing around with the Real Player plugin, while other plugins are installed, visiting all sorts of sites, but I haven't been able to crash.
See also bug 641249 - Windows media player plugin and realplayer are just not a good combination.
is there enough here and in bug 641249 for a relnote?
Keywords: relnote
So, after reading bug 641249 and playing around this a bit more I realized that I had a ton of submitted crashes I was not aware of, and they are all plugin crashes.

I was able to reproduce this easily: Install the latest Real Player using the installer you get from visiting www.real.com and having Windows Media Player installed from the AMO link. Visit http://www3.nhk.or.jp/nhkworld

This is not crashing the whole browser.
Crash Signature: [@ msvcr90.dll@0x25e45 ]
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.