Autocomplete suggestions could be show on the wrong element

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: vingtetun, Assigned: vingtetun)

Tracking

Details

(Whiteboard: [fennec-checkin-postrc])

Attachments

(1 attachment)

Created attachment 518856 [details] [diff] [review]
Patch

Steps to reproduce:
 * go to http://vingtetun.org/tmp/autocomplete.html
 * tap on the username textbox, type something and hit return
 * tap on the name textbox and hit the next button twice quickly

Actual result: The third field is focused and an autocomplete popup with the word typed for the second field show up

Expected result: The third field is focused and that's all


The patch fix this situation and include a similar fix for the caret where the bug lives for months now but since it is less visual it probably has been harder to observe or understand.

The patch also add a max-width: 0px to the suggestions element otherwise it _could_ force the left sidebar to be shown if it is long enough the _first_ time it is used.
Attachment #518856 - Flags: review?(mark.finkle)
Attachment #518856 - Flags: review?(mark.finkle) → review+
Whiteboard: [fennec-checkin-postrc]
Assignee: nobody → 21
http://hg.mozilla.org/mobile-browser/rev/8fd524f25466
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 2

7 years ago
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:5.0a2) Gecko/20110413 Firefox/5.0a2 Fennec /5.0a2 

Device: HTC Desire Z (Android 2.2), Sony Ericsson Xperia X 10 (Android 2.1 update 1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.