User is not remembered when he comes back to vote on answer

RESOLVED DUPLICATE of bug 688033

Status

RESOLVED DUPLICATE of bug 688033
8 years ago
7 years ago

People

(Reporter: atopal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
We ask people by mail to come back and rate and vote on answers, but when they do click on the link in the mail they come to the site as non-registered users and can't actually mark article as solved. 

Solution: Log people in when they register and remember log-in over 2 weeks.
Logging people in at registration time doesn't work because it allows them to skip the confirming their email address step--we actually do log them in momentarily and then log them back out.

A better solution is some kind of one-time-use key that logs them in automatically. In order to have the question public and someone post a solution, they have to have done the confirmation step.
Target Milestone: 2011Q2 → 2011Q3
(Reporter)

Comment 2

7 years ago
Yeah, I like the solution with the one time pad.

btw, James can we check how many people post a question, but don't follow through with the activation mail, so that their question is never posted?

We have like 8000 registrations per week and only about 3000 new questions, would like to see if there is a bottleneck, where we need to change the UX
(In reply to comment #2)
> James can we check how many people post a question, but don't follow
> through with the activation mail, so that their question is never posted?
In June, there were 1119 questions asked by users that never got activated (out of a total of 15303 questions asked).


In [7]: Question.objects.filter(creator__is_active=False, created__gt=datetime(2011,06,01), created__lt=datetime(2011,07,01)).count()
Out[7]: 1119

In [8]: Question.objects.filter(created__gt=datetime(2011,06,01), created__lt=datetime(2011,07,01)).count()
Out[8]: 15303
1119/15303 is about 7.3%. Maybe that could be lower, but it doesn't seem like the big issue. That makes it seem more like people aren't coming back to mark the answer as a solution.
(Reporter)

Comment 5

7 years ago
yeah, thanks a lot for the numbers!
(Reporter)

Comment 6

7 years ago
I mean that still means about 4000 people sign up every week without asking a new question, but good to know it's not mainly about people who don't understand the activation procedure.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Target Milestone: 2011Q3 → ---
Duplicate of bug: 688033
You need to log in before you can comment on or make changes to this bug.