Can't report using old charts using bugzilla 3.4.10

RESOLVED WORKSFORME

Status

()

Bugzilla
Reporting/Charting
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Denis Eperonnier, Unassigned)

Tracking

3.4.10
x86_64
Linux

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Bugzilla 3.4.10

After upgrading from bugzilla 3.4.8 to 3.4.10, I couldn't report using old charts anymore.
It is not a data problem since collectstats.pl runs every day and data files are present

Reproducible: Always

Steps to Reproduce:
1. Upgrade from Bugzilla 3.4.8 to 3.4.10
2. Go to Reports/old charts
3. try to chart anything
Actual Results:  
got server error, apache error_log reports:
[error] Call me again when you have some data to chart at /var/www/html/bugzilla/reports.cgi line 264\n


Expected Results:  
Picture with chart data, no server error

issue is present when running in mod_cgi or mod_perl

workaround: downgrade reports.cgi file only from 3.4.10 to 3.4.8, then old charts are available again

Updated

7 years ago
Keywords: qawanted

Comment 1

7 years ago
I cannot reproduce. Data are correctly displayed. We added a .htaccess file to the graphs/ directory, but that's not the reason of the error message. It's maybe a permission problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Version: unspecified → 3.4.10
(Reporter)

Comment 2

7 years ago
I already had a .htaccess file in the graphs/ directory:

# Allow access to .png and .gif files.
<FilesMatch (\.gif|\.png)$>
  Allow from all
</FilesMatch>

# And no directory listings, either.
Deny from all

This seems correct to me.

With reports.cgi 3.4.10, the graphs folder remains empty.

Note that I did upgrade from 3.4.8 to 3.4.10 via CVS.
When I get some time, I'll try with a clean checkout of 3.4.10 to be sure.

Comment 3

7 years ago
I have seen this same problem at a client's Bugzilla--it only happens for some data sets.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

7 years ago
I got a clean checkout of 3.4.10, same problem
I tried reports.cgi 3.4.9, still no graph

So for me only 3.4.8 works.

Is there any test I could made, any additional data I could provide?

Comment 5

6 years ago
Is this problem still present in Bugzilla 4.2? Bugzilla 3.4 is no longer supported.

Comment 6

5 years ago
Marking as WFM as I got no answer in the last 4 months.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

5 years ago
(In reply to Frédéric Buclin from comment #5)
> Is this problem still present in Bugzilla 4.2? Bugzilla 3.4 is no longer
> supported.

sorry for the late reply, but I can't remember receiving this email (might have been filtered by mistake)

We hope to be able to migrate to 4.2 soon, but we still have some work for that (template customization + 3rd party compatibility check)

I just retried the old chart using bz 3.4, and it works.
I must have updated or changed something, but in the end I agree on the WFM.
You need to log in before you can comment on or make changes to this bug.