Closed Bug 641290 Opened 10 years ago Closed 10 years ago

Increase in size of places.sqlite

Categories

(Toolkit :: Places, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jeffdewe, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

Basically if you change/add a site to your bookmarks toolbar the /root/.mozilla/firefox/kvmwarlf.default/places.sqlite <--- places.sqlite gets blown-up to 10MB in size, where as the previous Firefox 3-4b was only around 188kb, but the final in /root/.mozilla/firefox/kvmwarlf.default/places.sqlite is 10MB.
I then took an older beta4Firefox and tried it and the result was 188kb not 10MB like the latest firefox 4.0 final does, so this is a new bug only related to firefox4 final
Jeff


Reproducible: Always
Summary: /root/.mozilla/firefox/kvmwarlf.default/places.sqlite → Increase in size of places.sqlite
Version: unspecified → Trunk
Component: General → Places
Product: Firefox → Toolkit
QA Contact: general → places
This was by design. See bug 581606.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
No it was not, Are you telling me that places.sqlite went from 188kb to 10MB in file size from Firefox 4 beta to Firefox Final, if so what genius figures people have an extra 10MB of memory to toss out the door for absolutely nothing.
Jeff
Discussion about this can be found here:
https://groups.google.com/group/mozilla.dev.apps.firefox/browse_thread/thread/8970853c3e30b321#

This behavior is intentional.
Resolution: INVALID → WONTFIX
Also, I would HIGHLY recommend you not run the browser as root! That's a bad idea -- for any app -- for innumerable reasons.
(In reply to comment #4)
> Also, I would HIGHLY recommend you not run the browser as root! That's a bad
> idea -- for any app -- for innumerable reasons.

With traditional Linux distro's that is true, not with Puppy Linux, it runs 100% in ram, and the files system is squashed. Its been tested time and time again to be 100% secure.
Jeff
You need to log in before you can comment on or make changes to this bug.