The default bug view has changed. See this FAQ.

Reorder menus to promote tabs more after landing of bug 505311

VERIFIED FIXED in seamonkey2.1b3

Status

SeaMonkey
Tabbed Browser
--
enhancement
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Sven Grull, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.1b3
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

10.80 KB, patch
InvisibleSmiley
: review+
InvisibleSmiley
: superreview+
InvisibleSmiley
: ui-review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110309 Firefox/4.0b13pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b13pre) Gecko/20110309 Firefox/4.0b13pre SeaMonkey/2.1b3pre

The context menus should be changed after landing of bug 505311 according to Firefox bug 322736 to have "Open Link in New Tab" above "Open Link in New Window".
This was already mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=505311#c3 but discussion never happened.

Reproducible: Always
(Reporter)

Updated

6 years ago
blocking-seamonkey2.1: --- → ?
Depends on: 505311, 322736
(Assignee)

Updated

6 years ago
Severity: normal → enhancement
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Comment 1

6 years ago
Confirming RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

6 years ago
Created attachment 519004 [details] [diff] [review]
patch
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #519004 - Flags: ui-review?(neil)
Attachment #519004 - Flags: superreview?(neil)
Attachment #519004 - Flags: review?(mnyromyr)

Updated

6 years ago
Attachment #519004 - Flags: ui-review?(neil)
Attachment #519004 - Flags: ui-review+
Attachment #519004 - Flags: superreview?(neil)
Attachment #519004 - Flags: superreview+

Comment 3

6 years ago
Comment on attachment 519004 [details] [diff] [review]
patch

You covered browser and mail message body, but you missed mail folder and mail thread pane context, making mail menu order inconsistent.
Attachment #519004 - Flags: review?(mnyromyr) → review-

Comment 4

6 years ago
There is a Thunderbird bug to reorder their context menu. Perhaps you should spin off the Mailnews changes to another bug?
(Assignee)

Comment 5

6 years ago
Created attachment 519223 [details] [diff] [review]
patch v1a

(In reply to comment #3)
> You covered browser and mail message body, but you missed mail folder and mail
> thread pane context, making mail menu order inconsistent.

Good catch, TUVM!

(In reply to comment #4)
> There is a Thunderbird bug to reorder their context menu. Perhaps you should
> spin off the Mailnews changes to another bug?

I see absolutely no point at all in doing that.
Attachment #519004 - Attachment is obsolete: true
Attachment #519223 - Flags: ui-review+
Attachment #519223 - Flags: superreview+
Attachment #519223 - Flags: review?(mnyromyr)

Comment 6

6 years ago
Comment on attachment 519223 [details] [diff] [review]
patch v1a

Looks good so far, thus I'm plussing this one.
There are, however, more items missed:
- history window context
- history sidebar context
- bookmarks window context (single bookmark)
- bookmarks sidebar context (single bookmark)
and maybe others.
You should probably look out for menu text/items more generally.
Attachment #519223 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 7

6 years ago
Created attachment 519512 [details] [diff] [review]
patch v1b [Checkin: comment 8]

Thanks Karsten. I really should have checked thoroughly myself in the first place. Searched for "New Window" now:

cmd.open_window.label
common/bookmarks/placesOverlay.xul
common/history/placesOverlay.xul
> Done now.

openLinkCmd.label
common/contentAreaContextOverlay.xul
mailnews/mailWindowOverlay.xul
> Already done previously.

openFrameCmd.label
common/contentAreaContextOverlay.xul
> Done now.

newWinPageMenu.label
common/pref/pref-navigator.xul
> Window before Tab, but not really related -> leaving as is.

openFeedWebPageInWindow.label
mailnews/mailWindowOverlay.xul
> No tab option here.

openFeedSummaryInWindow.label
mailnews/mailWindowOverlay.xul
> No tab option here.

contextOpenNewWindow.label
mailnews/mailWindowOverlay.xul
> Already done previously.


Since I addressed all your findings now and pretty much ruled out that I missed anything I'll carry the flags forward and check in right away.
Attachment #519223 - Attachment is obsolete: true
Attachment #519512 - Flags: ui-review+
Attachment #519512 - Flags: superreview+
Attachment #519512 - Flags: review+
(Assignee)

Updated

6 years ago
Attachment #519512 - Attachment description: patch → patch v1b
(Assignee)

Comment 8

6 years ago
Comment on attachment 519512 [details] [diff] [review]
patch v1b [Checkin: comment 8]

http://hg.mozilla.org/comm-central/rev/a70e18e2ce57
Attachment #519512 - Attachment description: patch v1b → patch v1b [Checkin: comment 8]
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
blocking-seamonkey2.1: ? → ---
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1b3
http://hg.mozilla.org/comm-central/rev/c49e94c95321
(Bv1) Update test_contextmenu.html too.
(rs=bustage-fix).
Flags: in-testsuite+
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1300300344.1300302684.19766.gz
WINNT 5.2 comm-central-trunk debug test mochitests-5/5 on 2011/03/16 11:32:24

V.Fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.