No Direct3D hardware acceleration on a supported platform (Intel 915GM / Windows XP)

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: fijam7, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

According to https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#Intel_cards Intel 915GM should be supported with 6.14.10.4764 driver on Windows XP. However, there seem to be no Direct 3D acceleration for compositing in this configuration.

From about:support

Adapter Description Mobile Intel(R) 915GM/GMS,910GML Express Chipset 
Vendor ID 8086
Device ID 2592
Adapter RAM Unknown
Adapter Drivers igxprd32
Driver Version 6.14.10.4764
Driver Date 1-13-2007
Direct2D Enabled false
DirectWrite Enabled false (0.0.0.0, font cache n/a)
WebGL Renderer Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows 0/1

Acquarium demo, 1 fish, 5fps
http://webglsamples.googlecode.com/hg/aquarium/aquarium.html

HWACCEL demo, 8 fps
http://demos.hacks.mozilla.org/openweb/HWACCEL/

Flying Images, ~40fps
http://ie.microsoft.com/testdrive/Performance/FlyingImages/Default.html

Disabling/enabling hardware acceleration in Options > Advanced has no impact on fps in those tests. 

Setting webgl.force-enabled and layers.acceleration.force-enabled to true also makes no difference.

Reproducible: Always
Direct3D 9 composition is not enabled because of the Maximum Texture size being 2048x2048 on the 915GM if I'm not mistaking. We require 4096x4096, i.e. it's not blocked for any particular reason, but it's also not supported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.