Duplicate messages with Thunderbird on two PCs serving same mailbox

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Igor Novgorodov, Unassigned)

Tracking

1.9.2 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs protocol log])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.133 Safari/534.16
Build Identifier: 3.1.9

I have two instances of TB: at work, and at home, which are set up to handle a single mailbox using IMAP (Dovecot 2.0.11). They are often running simultaneously, and i'm getting duplicate messages very often, some of which are appearing even 3-5 times. When i shut down any of TBs, the duplicates seems to stop appearing.

What's the root of the problem? Maybe it's IMAP server or something else?
This annoying thing began some time ago, i dont actually remember when, but nothing gradually changed back then, maybe just TB got updated, and Dovecot too.

Reproducible: Always
Well looking at what's going on at the imap level would be the first thing to do in order to understand what's going on with your setup see https://wiki.mozilla.org/MailNews:Logging .

Comment 2

7 years ago
Moving to the IMAP component. Do you have any message filters set up in either of the Thunderbird instances which may interfere with each other?
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Version: unspecified → 1.9.2 Branch

Comment 3

7 years ago
preface to comment 2...
* is all this occurring in Inbox?
* duplicates appear on both PCs?
Summary: Duplicate messages with two instances of Thunderbird serving same mailbox → Duplicate messages with Thunderbird on two PCs serving same mailbox
Whiteboard: [needs protocol log]
(Reporter)

Comment 4

7 years ago
(In reply to comment #1)
> Well looking at what's going on at the imap level would be the first thing to
> do in order to understand what's going on with your setup see
> https://wiki.mozilla.org/MailNews:Logging .

Okay, i've enabled imap:5 logging, but it's getting larger and larger :)

(In reply to comment #2)
> Moving to the IMAP component. Do you have any message filters set up in either
> of the Thunderbird instances which may interfere with each other?

No, no local filters on any thunderbird, just server-side SIEVE filters, which are executed before delivery into maildir.

(In reply to comment #3)
> preface to comment 2...
> * is all this occurring in Inbox?
> * duplicates appear on both PCs?

As far as i can see, duplicates appear only in INBOX, and yes, they appear on both PCs, and they are not local phantomes, they also exist on the server in a maildir.
For example now i have 3 untouched duplicates, each of them having exactly the same size, but somehow only two of them are identical:

# md5sum:
1ae65af183cc50695d7bf4b0f8b9f6d0  1300264723.M359053P31849.mx,S=18557,W=18950:2,S
7dff7a564b538362c8da2b19692294f2  1300264723.M61949P18006.mx,S=18557,W=18950:2,S
1ae65af183cc50695d7bf4b0f8b9f6d0  1300264723.M720195P31849.mx,S=18557,W=18950:2,S
(Reporter)

Comment 5

7 years ago
Closing this one, as it seems to be a false alarm.
I had a ESET NOD32 addon installed automatically by A/V software, which seemed to be looping emails (some of them had hundreds of duplicate headers added by NOD32 with different IDs) and this addon seemed to be the cause of duplicates. Disabling it solved all the problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

7 years ago
May be we should blacklist this module or mark it incompatible with current version of TB to avoid further problems
What version of the A/V ?
(Reporter)

Comment 8

7 years ago
Well, it's constanly updates itself, but major version at install time was 4.2, now it's 4.2.64.12? plugin itself is "ESET Smart Security Extension 4.2.64.12", so it seems that the plugin is updated along with the main program.
You need to log in before you can comment on or make changes to this bug.