Last Comment Bug 641376 - Glitches of flash video plugin on Engadget.com site (flash plugin repeatable change position)
: Glitches of flash video plugin on Engadget.com site (flash plugin repeatable ...
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.engadget.com/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-13 14:16 PDT by kolubinowicki
Modified: 2012-05-16 13:46 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Recorded bug behavior. (989.27 KB, video/ogg)
2011-03-13 14:21 PDT, kolubinowicki
no flags Details
1Fps Cut Recorded bug behavior. (113.10 KB, video/ogg)
2011-03-13 14:22 PDT, kolubinowicki
no flags Details

Description kolubinowicki 2011-03-13 14:16:38 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110313 Firefox/4.0b13pre
Build Identifier: 

Check attachments for recorded glitches.

Engadget.com (posts from Mar 12th 2011 at 9:05PM)
Gecko/20110312 Firefox/4.0b13pre
Flash: 10.3.180.42
NO GPU acceleration 0/1
Windows 7 32bit

Reproducible: Always

Steps to Reproduce:
1.Open Engadget.com
2.See glitches  

Actual Results:  
Glitches on embedded flash video plugin

Expected Results:  
No glitches
Comment 1 Bas Schouten (:bas.schouten) 2011-03-13 14:20:22 PDT
I'm not sure this is actually graphics...
Comment 2 kolubinowicki 2011-03-13 14:21:00 PDT
Created attachment 519047 [details]
Recorded bug behavior.
Comment 3 kolubinowicki 2011-03-13 14:22:15 PDT
Created attachment 519048 [details]
1Fps Cut Recorded bug behavior.
Comment 4 kolubinowicki 2011-03-13 16:08:59 PDT
Problem also occur on stable flash 10.2.152.32
and also on Firefox 3.6.13 (latest checked version)
On Chrome and Opera flash work fine. 

Engadget.com Page specific problem?
Comment 5 pal-moz 2011-03-13 16:44:13 PDT
WFM (with OOPP enabled/disabled)

Win 7 32bit
Flash 10.2.152.32

Adapter Description : NVIDIA GeForce GTS 250
Vendor ID : 10de
Device ID : 0615
Adapter RAM : 1024
Adapter Drivers : nvd3dum nvwgf2um,nvwgf2um
Driver Version : 8.17.12.6658
Driver Date : 1-7-2011
Direct2D Enabled : true
DirectWrite Enabled : true (6.1.7601.17563, font cache 0.23 MB)
WebGL Renderer : Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows : 1/1 Direct3D 10
Comment 6 kolubinowicki 2011-03-13 18:02:17 PDT
In addition to comment 4 (sorry for bugspam). Bug occur for my computer specification from latest trunk version of Minefield (also on forced Gpu 1/1 direct 3d 9), to as far as latest checked Firefox 2.0.0.20, only on embedded video/flash on Engadget.com. In past I didn't notice any kind of glitches on that site. Also I don't install any new gpu driver, or exotic software that can harm system (except regular windows 7 updates :)
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-13 18:53:26 PDT
I see the bug. Maybe a Flash 10.2 bug?

A reduced testcase would probably help here.
Comment 8 Alice0775 White 2011-03-13 18:56:44 PDT
Confirmed
This problem happens on 
* Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.8.0.14eol) Gecko/20080308 Firefox/1.5.0.12eol
* Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.8.1.22pre) Gecko/20090415 BonEcho/2.0.0.22pre
* Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19
* Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.18pre) Gecko/20110304 Firefox/3.5.18pre ID:20110304030206
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16pre) Gecko/20110309 Namoroka/3.6.16pre ID:20110309033306
* Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110312 Firefox/4.0b13pre ID:20110312030414

However, not happen on
* Google Chrome 10.0.648.133
* Google Chrome 12.0.701.0 canary build
* Opera/9.80 (Windows NT 6.1; U; en) Presto/2.7.62 Version/11.01

I did not test the other browser.

And this also happens on Linux build
Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110313 Firefox/4.0b13pre ID:20110313030411
Comment 9 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-13 19:23:34 PDT
Could this be related to bug 635988?
Comment 10 Timothy Nikkel (:tnikkel) 2011-03-13 23:46:31 PDT
So a regression window won't be that helpful if it goes that far back (thanks for testing Alice!). All the reports so far have been with Flash >= 10.2 it looks like, so maybe the version of Flash used is important?
Comment 11 Warner Young 2011-03-14 10:16:30 PDT
If this is related to the version of Flash, then it may be any Flash >= 10.1, because I've been seeing this for quite a long time now.
Comment 12 fxtech 2011-03-14 11:59:51 PDT
i have it since 11 march , flash 10.2 , layer acceleration on , nvidia dx9 card , latest driver, d2d off
Comment 13 kolubinowicki 2012-05-16 13:46:47 PDT
Tested again link: 

http://www.engadget.com/2011/03/12/sprints-dan-hesse-differentiates-between-unlimited-and-unlimit/

and cannot reproduce anymore bug on:
Nightly 15.0a1,
Firefox 4.0
Firefox 12

with Flash Player version 11.2.202.235

Note You need to log in before you can comment on or make changes to this bug.