Sort lists of branches, tests, and platforms in 'Add Test Data' dialog

RESOLVED FIXED

Status

Webtools Graveyard
Graph Server
P3
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: nthomas, Assigned: mbrubeck)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
In the custom chart builder, there are lists which are (probably) sorted by id in their respective tables. It would be much more human friendly to sort alphabetically.
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
Priority: -- → P3
One thing that the original design calls for but is not yet implemented is the ability to have "popular" branches/tests/platforms on top:

http://people.mozilla.com/~chowse/drop/webtools/graph-server/v2/04_add_data.png

I might try to land this at the same time, because I think it'd be unfortunate if this change made Firefox not be at the top anymore ;)
Duplicate of this bug: 698426
Duplicate of this bug: 711298
graphs.m.o is deprecated in favor of datazilla at this point; not actively working on this
Assignee: rhelmer → nobody
(Assignee)

Comment 5

5 years ago
Created attachment 796084 [details] [diff] [review]
part 1: Sort the menu options by name

Note: Object.keys and Array.prototype.forEach are available in every widely used browser except IE8 and below.
Assignee: nobody → mbrubeck
Attachment #796084 - Flags: review?(rhelmer)
(Assignee)

Comment 6

5 years ago
Created attachment 796085 [details] [diff] [review]
part 2: Filter out branches with no data

With part 1 applied, it becomes more obvious that the menu contains many branches that are useless because there are no tests associated with them.
Attachment #796085 - Flags: review?(rhelmer)
Attachment #796084 - Flags: review?(rhelmer) → review+
Attachment #796085 - Flags: review?(rhelmer) → review+
This is great, thanks! Do you need me to land it?
Flags: needinfo?(mbrubeck)
(Assignee)

Comment 8

5 years ago
Nope!

http://hg.mozilla.org/graphs/rev/d9cdce203e2d
http://hg.mozilla.org/graphs/rev/f53cd87a3b97
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mbrubeck)
Resolution: --- → FIXED
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.