Module is not removed from UI after renaming

VERIFIED FIXED in Builder 0.9.2

Status

P2
normal
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: zalun, Assigned: zalun)

Tracking

unspecified
Builder 0.9.2
x86
Linux

Details

(Assignee)

Description

8 years ago
It is removed from the system (notification is displayed, module does not exist after reloading the page), but it stays in UI

Reproduction steps:

1. Create a module
2. Reload the page (to minimize the example to rename only)
3. Rename the module
4. Delete the module
5. Notification is displayed

Result:
Renamed module is still displayed

Desired result:
Renamed module is removed from UI
(Assignee)

Updated

8 years ago
Priority: -- → P2
Target Milestone: --- → Builder 0.9.2
Could this be due to a sync issue with local storage now that the tree runs off of that vs cookies?
(Assignee)

Comment 2

8 years ago
I don't think so - it behaves like it's not fully updated after renaming

Updated

8 years ago
Assignee: nobody → zaloon
fixed in master https://github.com/mozilla/FlightDeck/commit/dfd92f444ff3d770aeff38276432daa6637903f4
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.