Closed Bug 641506 Opened 9 years ago Closed 9 years ago

Seams that do not go away after panning in some pages

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

All
Android
defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: mbrubeck, Assigned: blassey)

References

Details

Attachments

(3 files)

Since bug 634397 and its dependencies landed, I see seaming while panning (expected) but sometimes the seam does not disappear when panning stops (unexpected).  Unfortunately I do not have a consistent repro case.
Summary: Seams that do not away after panning in some pages → Seams that do not go away after panning in some pages
Attached image screenshot
This screenshot from tarend (see the horizontal line of repeated pixels near the middle of the image) is typical of what I'm seeing.
Attached image Galaxy Tab screenshot
Here's another example.  See the line in the middle of the last paragraph that begins "imagine now...".  It's hard to see, but if you blow up this screenshot and move that line up, you'll find that it comes from the first line in the second paragraph, "The next wave..."

I've also seen examples where lines of pixels where omitted, rather than added.

I got this by panning down this page after double-tapping in the content to reflow zoom:
http://www.fastcompany.com/1736602/the-future-of-the-tablet-and-it-isn-t-the-ipad-2
Added logging to see whether we are calling redraw() when this happens.  It appears that we *are* calling it as expected, but the seam is still present.
tracking-fennec: ? → 2.0+
Duplicate of this bug: 641960
putting the redraw in a timeout seems to make this better in my testing, which leads me to believe that we have a race somewhere. Matt, can you confirm?
Attachment #519597 - Flags: feedback?(mbrubeck)
Comment on attachment 519597 [details] [diff] [review]
put the redraw in a timeout

>+          win.setTimeout(
>+            function() {
>+              winCwu20.redraw();
>+            }, 10);

Use 0, which basically is enough to "fix" races and is actually 10 in Mozilla

Let's get more verification that this fixes the problem.
Attachment #519597 - Flags: feedback?(mbrubeck) → feedback+
Comment on attachment 519597 [details] [diff] [review]
put the redraw in a timeout

I was not able to reproduce the problem with this patch applied.
Attachment #519597 - Flags: feedback+
Attachment #519597 - Flags: review?(mark.finkle)
Comment on attachment 519597 [details] [diff] [review]
put the redraw in a timeout

r+ with the 10 -> 0 change
Attachment #519597 - Flags: review?(mark.finkle) → review+
pushed https://hg.mozilla.org/mobile-browser/rev/90d505ee8f9b
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified:

Mozilla/5.0 (Android; Linux armv71; rv2.0b13pre) Gecko/20110316 Firefox/4.0b13pre Fennec/4.0b6pre
Device: Droid 2 
OS: Android 2.2
Status: RESOLVED → VERIFIED
Assignee: nobody → blassey.bugs
You need to log in before you can comment on or make changes to this bug.