If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

recent twittercollage update broke on staging

RESOLVED FIXED

Status

Websites
Other
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: noahm, Assigned: Andre Torgal)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
Following the CHANGELOG, I updated the Jobs section of config.yaml to define the hasCronSchedule keys.  With those keys in place, utils/configure.php fails:

[root@mrapp-stage04 twittercollage.allizom.org]# php util/configure.php 
>>>2011-03-14 08:50:04 | 1300117804 > configure.php > ERROR Cannot use a scalar value as an array (/data/www/twittercollage.allizom.org/lib/spyc-0.4.5/spyc.php:775) 
------ Array
(
    [0] => 2
    [1] => Cannot use a scalar value as an array
    [2] => /data/www/twittercollage.allizom.org/lib/spyc-0.4.5/spyc.php
    [3] => 775
    [4] => Array
        (
            [incoming_data] => a:1:{s:13:"image-process";s:0:"";}
            [incoming_indent] => i:4;
            [key] => s:13:"image-process";
            [value] => s:0:"";
            [history] => a:3:{i:0;a:7:{s:3:"App";a:4:{s:4:"path";s:36:"/data/www/twittercollage.allizom.org";s:7:"pathLog";s:
            [_arr] => i:0;
            [k] => s:15:"hasCronSchedule";
        )

)
 ERROR Cannot use a scalar value as an array (/data/www/twittercollage.allizom.org/lib/spyc-0.4.5/spyc.php:775)
>>>2011-03-14 08:50:04 | 1300117804 > configure.php > TERMINATE (ERROR)  Sorry, something went terribly wrong. TERMINATE (ERROR) 

The full jobs section from our config.yaml looks like:
Jobs:
    twitter-search:
        period: 10
        hasCronSchedule: 0
    image-process:
        period: 1
        dbLimit: 100
        imgLimit: 1000
        hasCronSchedule: 0
    mosaic-build:
        period: 5
        hasCronSchedule: 0

Do you see anything immediately wrong with this?
(Assignee)

Comment 1

7 years ago
I don't see anything wroing with it, but it's clearly a YAML error. Are you sure you are using spaces only for indentation?

Maybe if you send use/attach the actual file we can tell where the problem is

Also, if you are planning to deploy the jobs as cron jobs you will need to make hasCronSchedule: 1 in each job config.
(Reporter)

Comment 2

7 years ago
*grumble*

Yeah, it was a tab in the yaml.  Fixed that, and things are OK now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

7 years ago
Please pull again, I was inspecting http://twittercollage.allizom.org/en-US and found out our minification script was broken.

Will you close Bug 641512 as well?
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> Please pull again, I was inspecting http://twittercollage.allizom.org/en-US and
> found out our minification script was broken.

Pulled.

> Will you close Bug 641512 as well?

I'm currently seeing the behavior from 641512. It doesn't appear resolved in staging currently.
You need to log in before you can comment on or make changes to this bug.