TI+JM: Assertion failure: Call site vanished., at ../methodjit/Compiler.cpp:2460

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jandem, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-jaegermonkey)

(Reporter)

Description

7 years ago
$ ./js -a -m -n
js> var o = {};
js> o[o.p] = 2;
Assertion failure: Call site vanished., at ../methodjit/Compiler.cpp:2460
Duplicate of this bug: 642151
Add a couple of missing recompilation rejoin points for SETELEM.

http://hg.mozilla.org/projects/jaegermonkey/rev/61b3cd5aaee1
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: fixed-in-jaegermonkey
You need to log in before you can comment on or make changes to this bug.