Localized twitterparty does not play well with logo

VERIFIED FIXED

Status

www.mozilla.org
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: rbillings, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
Created attachment 519182 [details]
fr twitterparty

The translated text for joining the twitterparty doesn't fit well in the logo-see screenshot.

EX: http://dev.twitterparty.quodis.com/fr
Blocks: 607132
Quodis, could you take a look at this?

See bug 641697 comment 7 for how to create custom CSS per locale. Let us know if you need any guidance.
Quodis implemented a mechanism allowing localizers to specify custom CSS rules to control the layout.

An example for Polish:

https://localize.mozilla.org/pl/twitterparty/LC_MESSAGES/messages.po/translate/?unit=849871

It's up to the localizers to fix this (and to some extend, me and Gandalf), but we weren't able to do this until today because there was no working stage with working locales on it.

I will be posting tonight to the newsgroups about the staging server, which will allow the localizers to check their translations and fix the CSS.

I will probably mention both http://twitterparty.allizom.org/ and http://dev.twitterparty.quodis.com/  It looks like the first one might be going through a change of systems/machines today and tomorrow, so it might be offline or broken.
(Reporter)

Comment 4

7 years ago
ATM no localizations display in any locale logos so this cannot be verified at this time [also noted that it's up to the localizers to fix].

Comment 5

7 years ago
Both localizers and Rebecca can follow updates on Quodis site. It's stable and has all translations updated (I hope, Stas can confirm this).

http://dev.twitterparty.quodis.com/pt-PT

Comment 6

7 years ago
One of the causes of the logo problems is the insertion of extra semantic and visual elements in the HTML... the original bubble contains 3 pieces of information and we believe it should rest that way.

The case of the portuguese translation is demonstrative: This invite reads needlessly literary. Like the localizer thought it wouldn't be "correct" portuguese without the "do" proposition in a phrase.

Portuguese and Greek localizers may have thought it should be a phrase instead of a claim. 

Moreover the inserted <p> can't even be properly addressed with CSS because there was already another classless <p> inside #brand.

If you choose to drop it all the CSS pt-PT needs is: 

#brand h2 {font-size: 26px;}
(Reporter)

Comment 7

7 years ago
Localizations are up, and logo issues persist- I guess I'll wait on localizers to work on them more.

Comment 8

7 years ago
Created attachment 520644 [details]
CSS tweaks per localization (logo and footer buttons)

Comment 9

7 years ago
Attached a file with CSS tweaks per language. 

We didn't took this changes to the main index file because we were afraid that current or further tweaks made by localizerts could confict.

We have addressed some of the issues globaly in our CSS, the remainder is in the attached file.

Please fwd the changes to localizers.

Comment 10

7 years ago
Also, very important is the question raised in comment 6

Portuguese and Greek translations have extra html elements in the logo. These extra elements should be removed by localizers.

Since we're portuguese ourselves over here, we can guarantee you that the propostion "do" (means of) is totally unnecessary in an invitation.

Comment 11

7 years ago
Since we worked in this tweaks, the Russion translation was simplified and one of the tweaks in the above attachment should not be used.

#brand h1 { font-size: 22px; }

Comment 12

7 years ago
Marked bug 643200 as Fixed so we can concentrate all communication here (please verify it)

Please post all comments regarding Logo or any other elements that may still be broken in this ticket.
The fixes from Andre's attachment (comment 8) plus some additional ones have been applied.  Thanks so much, Andre!

Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 14

7 years ago
Thanks. But I'm just being the proxy for the Quodis team here.
(Reporter)

Comment 15

7 years ago
Verified looks much better
Status: RESOLVED → VERIFIED

Comment 16

7 years ago
Created attachment 520856 [details]
CSS tweaks per localization (revision 2, complete blocks)

Comment 17

7 years ago
Created attachment 520859 [details]
CSS tweaks per localization (revision 3, complete blocks)
Attachment #520644 - Attachment is obsolete: true
Attachment #520856 - Attachment is obsolete: true

Comment 18

7 years ago
Reviewed all localizations and updated the above attachement.

For each language included in your file please replace the entire contents of css localization with the supplied block.

Please make sure all these changes go through. Here's what it fixes:

- fixes the problems detected on linux (affects some default serifs for users that don't have georgia).
- fixes glitch on pt-BR, pt-PT and a few other footers
- repeats fixes for some other languages previously tweaks sent by quodis but did not get through to the CVS.
- fixes the excessive css (even font-family was changed) in pl, replacing it with a streamlined fix.
Resolution: FIXED → INCOMPLETE
I'm updating the CSS right now with rules from attachment 520859 [details].
Status: VERIFIED → REOPENED
Resolution: INCOMPLETE → ---
OK, all CSS has been updated to match Andre's tweaks from attachment 520859 [details].  Thanks again, Andre and the rest of the Quodis team.

Now, let's find a staging server that autoupdates and verify this :)
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 21

7 years ago
Logos and buttons look great- please re-open if final fixes were not updated correctly, every locale I looked at no longer displayed the original issue.
Status: RESOLVED → VERIFIED

Comment 22

7 years ago
sweet!
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.