Closed Bug 641789 Opened 9 years ago Closed 9 years ago

log uploader status module needs to cope with logs not existing

Categories

(Release Engineering :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 627310

People

(Reporter: bhearsum, Unassigned)

Details

We see this case whenever a slave gets hung mid-job and we don't notice until
after a something has cleaned up its master-side logs. This causes some Exceptions in upstream Buildbot (bug 641788), but our log uploader also doesn't cope, throwing exceptions like this:
2011-03-13 19:51:57-0700 [Broker,49612,10.12.50.20] Unhandled Error
	Traceback (most recent call last):
	  File "/tools/python-2.6.5/lib/python2.6/threading.py", line 484, in run
	    self.__target(*self.__args, **self.__kwargs)
	  File "/builds/buildbot/tests_master6/lib/python2.6/site-packages/twisted/python/threadpool.py", line 207, in _worker
	    result = context.call(ctx, function, *args, **kwargs)
	  File "/builds/buildbot/tests_master6/lib/python2.6/site-packages/twisted/python/context.py", line 59, in callWithContext
	    return self.currentContext().callWithContext(ctx, func, *args, **kw)
	  File "/builds/buildbot/tests_master6/lib/python2.6/site-packages/twisted/python/context.py", line 37, in callWithContext
	    return func(*args,**kw)
	--- <exception caught here> ---
	  File "/builds/buildbot/tests_master6/lib/python2.6/site-packages/buildbotcustom/status/log_handlers.py", line 95, in handleLogs
	    subprocess.check_call(cmd, stdout=output, stderr=subprocess.STDOUT)
	  File "/tools/python-2.6.5/lib/python2.6/subprocess.py", line 498, in check_call
	    raise CalledProcessError(retcode, cmd)
	subprocess.CalledProcessError: Command '['/builds/buildbot/tests_master6/bin/python', '/builds/buildbot/tests_master6/lib/python2.6/site-packages/buildbotcustom/bin/log_uploader.py', 'stage.mozilla.org', '-u', 'ffxbld', '-i', '/home/cltbld/.ssh/ffxbld_dsa', '-b', 'mozilla-central', '-p', 'macosx', '././mozilla-central_leopard-o-debug_test-jetpack', '343']' returned non-zero exit status 1


I think we should be catching these and reporting them in a friendlier way.
Dupe of 627310?

What's the desired behaviour here?  Silently ignore it?  Log a warning?  Log a nicer error?
(In reply to comment #1)
> Dupe of 627310?
> 
> What's the desired behaviour here?  Silently ignore it?  Log a warning?  Log a
> nicer error?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627310
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.