"Private bytes" RAM consumption goes extra large when downloading a big file in private browsing mode

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: TheOne, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I tried to make an educated guess about the component for this bug, please move it if it was not educated enough :)

Some hours ago, I downloaded a rather big file (a bit more than 1GB) when browsing in private mode.
The speed was rather slow, about 500-600 KB/s, so it took a while.
At around 90% of the download I noticed that my system was completely hanging more and more.
Firefox used about 2,5GB "Private Bytes" of RAM, and I guess it would have been even more, but my system was already swapping permanently.
After the download finished, RAM consumption was back to normal (about 400MB).

The whole time, Firefox itself (and the download manager ran in background) meaning I was not using it. Firefox itself had only one tab open (with mozilla the default  homepage).

I couldn't reproduce it on my second try though.



Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
(Firefox 4 RC1)
Presumably this is because we're keeping the file in memory instead of on disk or something?
(In reply to comment #1)
> Presumably this is because we're keeping the file in memory instead of on disk
> or something?
We only buffer it a little bit before writing to disk, so I find that unlikely.

Comment 3

7 years ago
(In reply to comment #1)
> Presumably this is because we're keeping the file in memory instead of on disk
> or something?

We only keep the downloads sqlite table in memory during PB mode.

Comment 4

5 years ago
Andreas, doe sthis still reproduce?
(Reporter)

Comment 5

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> Andreas, doe sthis still reproduce?

No. Closing this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.