Upgrade gcc 4.5 on buildbots

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: glandium, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Building current mozilla central with gcc 4.5 from /tools/gcc-4.5 (I believe this is 4.5.1) with the -O3 patch from bug 590181 applied leads to several failures in various tests (most notably plugin failures and some reftest problems). However, this doesn't happen on a local build with either 4.5.2 from Debian (svn revision 170696) or a plain 4.5.2 from upstream gcc.

As a consequence, could you package gcc 4.5.2 and upgrade gcc on the buildbots?
Assignee: nobody → rail
Priority: -- → P3
(Reporter)

Comment 1

7 years ago
Hold on, this is crazy, I can't even reproduce the problem the buildbots exhibit when I use the binaries from try.
(Reporter)

Comment 2

7 years ago
It was pretty dumb... libnptest.so of my try depended on libstdc++ 4.5.

So, now that it's a non issue, do we still want to bump gcc 4.5 version ?
If you don't need the newer version, then I'd just resolve this INCOMPLETE or WONTFIX.
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> If you don't need the newer version, then I'd just resolve this INCOMPLETE or
> WONTFIX.

The question was whether there'd be another rationale to push a newer version. Better to bump it before actually switching, if we want to.
(In reply to comment #4)
> (In reply to comment #3)
> > If you don't need the newer version, then I'd just resolve this INCOMPLETE or
> > WONTFIX.
> 
> The question was whether there'd be another rationale to push a newer version.
> Better to bump it before actually switching, if we want to.

agreed. easier to change now than later.
(In reply to comment #5)
> agreed. easier to change now than later.

Yeah, risk is very low. Let's upgrade it.
Priority: P3 → P2
Created attachment 519878 [details] [diff] [review]
RPM spec changes

I dropped linux64-ffi.diff patch which exists in 4.5.2.
Attachment #519878 - Flags: review?(catlee)
Created attachment 519879 [details] [diff] [review]
puppet

some of the staging build slaves got this ;)
Attachment #519879 - Flags: review?(catlee)

Updated

7 years ago
Attachment #519878 - Flags: review?(catlee) → review+

Updated

7 years ago
Attachment #519879 - Flags: review?(catlee) → review+
(Reporter)

Comment 9

7 years ago
Please hold on before building and deploying with this spec file. I may have a request for some specific build flags.
(In reply to comment #9)
> Please hold on before building and deploying with this spec file. I may have a
> request for some specific build flags.

Sure.
(Reporter)

Comment 11

7 years ago
Turns out the flags I was interested in are used by default, so you can go ahead :)
Comment on attachment 519878 [details] [diff] [review]
RPM spec changes

http://hg.mozilla.org/build/rpm-sources/rev/44f2e9f4c65f
Attachment #519878 - Flags: checked-in+
Comment on attachment 519879 [details] [diff] [review]
puppet

http://hg.mozilla.org/build/puppet-manifests/rev/19af7fd3219d
Attachment #519879 - Flags: checked-in+
gcc-4.5.2 deployment has just started. I'll check the result tomorrow.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Blocks: 643561
(Reporter)

Comment 15

7 years ago
Is it possible to get the resulting rpm ?
Sure: http://people.mozilla.org/~raliiev/gcc/
(Reporter)

Updated

7 years ago
Blocks: 559964
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.