Last Comment Bug 641871 - Block malware addon
: Block malware addon
Status: RESOLVED INCOMPLETE
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: 2013-09-10
Assigned To: Jorge Villalobos [:jorgev]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-15 10:08 PDT by Alexandre Poirot [:ochameau]
Modified: 2016-03-07 15:30 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alexandre Poirot [:ochameau] 2011-03-15 10:08:31 PDT
I ended up having two malicious addons installed in my firefox/extensions directory:
 - pdfforge@mybrowserbar.com
 - wtxpcom@mybrowserbar.com
I immediatly deleted them as I never authorized anything to install, addons nor any software.
These addons contained multiple native xpcom components.
pdfforge added a toolbar.
Comment 1 Alexandre Poirot [:ochameau] 2011-03-15 10:33:29 PDT
Here is additional info about these addons:
http://www.mularien.com/blog/2009/03/24/sourceforge-hosted-pdfcreator-trojantoolbar-warning/

I didn't installed PDFCreator recently, but I used it! It should have automatically install this stuff.
Comment 2 Jorge Villalobos [:jorgev] 2013-06-18 13:32:37 PDT
Kris, Tyler: can one of you please check if the installer silently installs any add-ons or does anything wrong?

http://www.pdfforge.org/
Comment 3 Tyler Downer [:Tyler] 2013-06-26 15:03:43 PDT
This does install an addon, but it seems to be just there to convert pages to PDF's and doesn't install silently or anything.
Comment 4 Kris Maglione [:kmag] 2013-06-26 15:06:37 PDT
Hm. Did you keep a copy of the add-ons? I was under the impression that @mybrowserbar.com add-ons were all pretty much the same search toolbar crapware, without any real functionality.
Comment 5 Jorge Villalobos [:jorgev] 2013-09-06 15:44:42 PDT
There doesn't seem to be any pending actions here. Please reopen if there's more information that warrants reconsidering.

Note You need to log in before you can comment on or make changes to this bug.