NS_ERROR_FAILURE in nsIProcess.run upon starting test-run

VERIFIED FIXED

Status

Mozilla QA Graveyard
Mozmill Crowd Extension
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: whimboo)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
On using the released (0.1.1) version as well as testing with a checkout of master, upon starting a test-run on OS X, I get:

Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProcess.run]

This occurs after selecting a directory for the environment, and after the environment is downloaded and extracted. See attached screenshot.

Running manually on command line works fine.

Tested with 4.0RC and a recent trunk nightly.
(Reporter)

Comment 1

7 years ago
Created attachment 519452 [details]
NS_ERROR_FAILURE Screenshot
(Assignee)

Comment 2

7 years ago
So that was based on the Mercurial failure you pointed out on IRC?
(Reporter)

Comment 3

7 years ago
This is something different AFAIK, still encountering this after my workaround.
(Reporter)

Comment 4

7 years ago
Created attachment 519475 [details]
NS_ERROR_FILE_NOT_FOUND Screenshot

On Ubuntu, after the same conditions I get

Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFileInputStream.init]
(Reporter)

Comment 5

7 years ago
As for the first error on Mac, the problem is with process.run

https://github.com/whimboo/mozmill-crowd/blob/master/extension/resource/environment.js#L86

I noticed that aScript is [xpconnect wrapped nsIFile], when dumped to console, and process is [xpconnect wrapped nsIProcess], is there any way to see why run() is failing?
(Assignee)

Comment 6

7 years ago
Probably my fault. The wrapper scripts aren't executable anymore.
Assignee: nobody → hskupin
Blocks: 641897
Status: NEW → ASSIGNED
(Assignee)

Comment 7

7 years ago
That was a failure in updating the test environment. I have simply copied over the script into the archive. I have re-created those environments from the repository and uploaded them. It should work now. Please check.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

7 years ago
Beauty, works great now. Thanks
Status: RESOLVED → VERIFIED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.