404 for most stacks/frames under topcrasher/byurl for a few Firefox versions

VERIFIED FIXED in 1.7.7

Status

Socorro
Webapp
VERIFIED FIXED
7 years ago
4 years ago

People

(Reporter: stephend, Assigned: brandon)

Tracking

Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
STR:

1. Load https://crash-stats.stage.mozilla.com/topcrasher/byurl/Firefox/4.0b13pre or https://crash-stats.stage.mozilla.com/topcrasher/byurl/Firefox/3.6.14
2. Click on "Expand http://www.facebook.com"
3. Click on the "ExecuteTree" stack/frame

Actual Results:

https://crash-stats.stage.mozilla.com/report/list?product=Firefox&version=Firefox%3A3.6.14&date=&range_value=1&range_unit=weeks&query_search=signature&query=ExecuteTree&query_type=exact&do_query=1&signature=ExecuteTree

[12:46:21.183] GET https://crash-stats.stage.mozilla.com/report/list?product=Firefox&version=Firefox%3A3.6.14&date=&range_value=1&range_unit=weeks&query_search=signature&query=ExecuteTree&query_type=exact&do_query=1&signature=ExecuteTree [HTTP/1.1 404 Not Found 130ms]
Flags: in-testsuite?

Updated

7 years ago
Assignee: nobody → laura
Assignee: laura → rhelmer
Status: NEW → ASSIGNED
I see this on prod too, not sure if it's a regression:

https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A4.0b13pre&date=&range_value=1&range_unit=weeks&query_search=signature&query=mozilla::%60anonymous%20namespace

I can't seem to follow the steps from comment 0 in stage, but I can find a bunch just trying all signatures under facebook.com
(Reporter)

Comment 2

7 years ago
Rob, yeah, it's changed since I filed -- but it still happens, seemingly random.
Keywords: regression
Is this a case of bug 561920/bug 569178, or is it some sort of other 404/No data for this location error (I can't really tell from the descriptions/links)?
Target Milestone: 1.7.7 → 1.7.8
(Reporter)

Comment 4

7 years ago
Are we sure this isn't something we want to address until 1.7.8?  If it's truly a data issue, that's one thing, but I'm concerned that there's a disparity -- links populated in the UI should have data behind them, no?  Even on staging?
(In reply to comment #4)
> Are we sure this isn't something we want to address until 1.7.8?  If it's truly
> a data issue, that's one thing, but I'm concerned that there's a disparity --
> links populated in the UI should have data behind them, no?  Even on staging?

I don't think it's a data issue, from looking into it yesterday I suspect that something is wrong with the topCrashByUrl/topCrashByDomain reports, and that the same problem exists on production.

Here is an example:

1) https://crash-stats.mozilla.com/topcrasher/bydomain/Firefox/4.2a1pre
2) expand facebook.com
3) select nsIBoxObject_GetHeight -> https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A4.2a1pre&date=&range_value=1&range_unit=weeks&query_search=signature&query=nsIBoxObject_GetHeight&query_type=exact&do_query=1&signature=nsIBoxObject_GetHeight

This signature does exist in the system, but not for that version (4.2a1pre) but only for 4.0:

https://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=nsIBoxObject_GetHeight&date=04%2F12%2F2011%2009%3A18%3A54&range_value=1&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsIBoxObject_GetHeight

This looks a lot like the same behavior I see testing this on staging. My guess is that either the report cron or the PHP UI are not restricting the domain/url reports to the correct version number.
(Reporter)

Comment 6

7 years ago
It's broader than the scope of this bug, I think, but I ran a link checker on staging, and published a report of all the broken links: https://dl-web.dropbox.com/get/Public/broken-links.htm?w=7977b432
(Reporter)

Comment 7

7 years ago
Given comment 5, is this something we'd want to fix in 1.7.7?

Comment 8

7 years ago
Rob: do you have time to pick this up for 1.7.7?  If not, you can sling it to bsavage.
Assignee: rhelmer → bsavage
(Assignee)

Comment 9

7 years ago
Created attachment 526072 [details] [diff] [review]
Javscript range patch

The report is set to two weeks, but the URL constructed by the javascript only contains a range of 1 week. When manually changing the range from 1 to 2 on staging, this resolved the issue.
Attachment #526072 - Flags: review?(laura)
Attachment #526072 - Flags: feedback?(rhelmer)
The patch helps, but doesn't resolve all of the issues.  See for example STR:
1. Go to https://crash-stats.mozilla.com/topcrasher/bydomain/Firefox/4.2a1pre
2.  Expand facebook.com
3.  Click on stack frame
::~nsRefPtr() | nsBaseCommandController::`scalar deleting destructor''(unsigned int)'>nsRefPtr::~nsRefPtr() | nsBaseCommandController::`scalar deleting destructor''(unsigned int)
4 See that the link is to one week's data e.g.
https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A4.2a1pre&date=&range_value=1&range_unit=weeks&query_search=signature&query=nsRefPtr%3CnsIDOMEventListener%3E::~nsRefPtr%3CnsIDOMEventListener%3E%28%29%20|%20nsBaseCommandController::%60scalar%20deleting%20destructor
and that there is no data.

5.  As per the patch, convert this to 2 weeks
https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A4.2a1pre&date=&range_value=2&range_unit=weeks&query_search=signature&query=nsRefPtr%3CnsIDOMEventListener%3E::~nsRefPtr%3CnsIDOMEventListener%3E%28%29%20|%20nsBaseCommandController::%60scalar%20deleting%20destructor
and see that there is still no data.

Updated

7 years ago
Attachment #526072 - Flags: review?(laura) → review-
(Assignee)

Comment 11

7 years ago
Created attachment 526121 [details] [diff] [review]
Both fixing the encoding and the way the URLs are presented

Further investigation discovered that certain HTML entities, along with an unencoded URL, was creating issues. Identified a similar set of signatures producing the same issue in dev against which to test. This patch encodes the URL and htmlentities properly, as well as displays the correct number of weeks as part of the report URL.
Attachment #526072 - Attachment is obsolete: true
Attachment #526072 - Flags: feedback?(rhelmer)
Attachment #526121 - Flags: review?(rhelmer)
Attachment #526121 - Flags: feedback?(laura)
Comment on attachment 526121 [details] [diff] [review]
Both fixing the encoding and the way the URLs are presented

This approach seems fine to me. I tested in my dev instance (pointing to staging DB) and it seems to work fine as well. Lack of escaping also causes Kohana to error out with "Disallowed key characters in global data." for certain signatures linked from this report, which this also fixes.

This approach does make the JSON slightly larger (since it now carries the signature twice, once URL-encoded and once HTML-encoded) but we discussed in irc and agree that it's more readable/safer than doing it in JS at the moment (jQuery's .html() would work, but we're getting the value from a .getJSON() XHR so we'd have to wrap it in an HTML element to get it into jQuery, which is fairly confusing).

However, if there's a more straightforward way to do HTML-encoding from JS right now I'd be all for it.
Attachment #526121 - Flags: review?(rhelmer) → review+
(Assignee)

Comment 13

7 years ago
The patch above was committed in revision 3056.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: 1.7.8 → 1.7.7
(Reporter)

Comment 14

7 years ago
Verified FIXED on staging -- Matt, please put this one on the top of the priority list for automation, when you get a chance; thanks!
Status: RESOLVED → VERIFIED
(In reply to comment #14)
> Verified FIXED on staging -- Matt, please put this one on the top of the
> priority list for automation, when you get a chance; thanks!

Sounds good ... consider it moved to the top of the priority list. Now the real question, when's the due date for getting the automation in?
(Assignee)

Updated

6 years ago
Duplicate of this bug: 586185
Component: Socorro → General
Product: Webtools → Socorro
(Reporter)

Updated

6 years ago
Component: General → Webapp
(Reporter)

Updated

6 years ago
Flags: in-testsuite?

Updated

4 years ago
Attachment #526121 - Flags: feedback?(laura)
You need to log in before you can comment on or make changes to this bug.