Last Comment Bug 641942 - Make Windows progress bars RTL-friendly
: Make Windows progress bars RTL-friendly
Status: VERIFIED FIXED
: rtl
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
data:text/html,<p>ltr:</p><progress v...
Depends on: 641517 641905 672782
Blocks: 633207
  Show dependency treegraph
 
Reported: 2011-03-15 13:31 PDT by Mounir Lamouri (:mounir)
Modified: 2011-07-20 08:12 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.54 KB, patch)
2011-03-17 11:56 PDT, Mounir Lamouri (:mounir)
jmathies: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-03-15 13:31:40 PDT
They are shown with the bar on the right because this is managed by the layout code but the animations are done by the widget code and currently do not take into account RTL.
Comment 1 :Ehsan Akhgari (away Aug 1-5) 2011-03-16 14:13:37 PDT
Can you elaborate on what you mean in comment 0?
Comment 2 Mounir Lamouri (:mounir) 2011-03-17 11:30:16 PDT
<progress value=0.5> in LTR will be shown like:
[*****     ]
In RTL:
[     *****]

But, on Windows (Vista and later), there is animated glow on the progress bars which, for the moment, goes from left to right.

In addition, indeterminate progress bars also go from left to right.

You can try the URL with this build to have a look:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/mlamouri@mozilla.com-3665ab582961/
Comment 3 Mounir Lamouri (:mounir) 2011-03-17 11:56:26 PDT
Created attachment 519977 [details] [diff] [review]
Patch v1
Comment 4 :Ehsan Akhgari (away Aug 1-5) 2011-03-17 13:16:06 PDT
(In reply to comment #2)
> <progress value=0.5> in LTR will be shown like:
> [*****     ]
> In RTL:
> [     *****]
> 
> But, on Windows (Vista and later), there is animated glow on the progress bars
> which, for the moment, goes from left to right.

I see, makes sense.
Comment 5 Jim Mathies [:jimm] 2011-04-25 06:12:21 PDT
Comment on attachment 519977 [details] [diff] [review]
Patch v1

Review of attachment 519977 [details] [diff] [review]:

r+
Comment 6 Mounir Lamouri (:mounir) 2011-05-09 05:45:00 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/ea4a5a20e081
Comment 7 Shawn Wilsher :sdwilsh 2011-05-09 16:12:22 PDT
Backed out in http://hg.mozilla.org/mozilla-central/rev/dd9ba28d2bd9 to resolve bug 655860.
Comment 8 Mounir Lamouri (:mounir) 2011-05-10 07:02:47 PDT
The regression wasn't caused by these patches. Re-landed:
http://hg.mozilla.org/mozilla-central/rev/e0b0a18a6905
Comment 9 George Carstoiu 2011-07-20 06:16:30 PDT
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

Checked this issue using an 'ar' Fx 6.0b2 build.

Yes, the animation is moving from right to left as it should be, but what concerns me is that it doesn't have a consistent pattern - sometimes it disappears and reapers a few centimeters away, it doesn't always start from the beginning of the progress bar.

Considering this, I am setting the status of the bug to Reopened.
Comment 10 Jim Mathies [:jimm] 2011-07-20 06:32:33 PDT
(In reply to comment #9)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
> 
> Checked this issue using an 'ar' Fx 6.0b2 build.
> 
> Yes, the animation is moving from right to left as it should be, but what
> concerns me is that it doesn't have a consistent pattern - sometimes it
> disappears and reapers a few centimeters away, it doesn't always start from
> the beginning of the progress bar.
> 
> Considering this, I am setting the status of the bug to Reopened.

Could you file a new bug George and mark it as blocking this one? (Lets keep this one closed since patches landed here.)
Comment 11 George Carstoiu 2011-07-20 06:43:47 PDT
Logged Bug 672782.

Setting the resolution of this issue to Verified Fixed, as RTL animation was introduced.

Note You need to log in before you can comment on or make changes to this bug.