Keystrokes not detected after alert/confirm due to focus not being returned to active document

RESOLVED DUPLICATE of bug 617507

Status

()

--
major
RESOLVED DUPLICATE of bug 617507
8 years ago
8 years ago

People

(Reporter: bramus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Many webapps have built-in hotkeys support, by listening to keyup/keypress events via JavaScript. All works fine and dandy, until an alert or a confirm is presented to the user. 

After confirming the alert/confirm, no more keystrokes are detected, unless one explicitly focuses the document again.

Reproducible: Always

Steps to Reproduce:
1. Listen to keystrokes via javascript (document.onkeyup or window.onkeyup)
2. Trigger an alert or a confirm on any keystroke
Actual Results:  
The first keystroke will be detected and the alert/confirm will be shown. From then on, all succeeding keystrokes won't be detected anymore.

Only way to fix this is the click on the document, and thus forcing focus back on the active document again.

An other way to fix this, is to switch to an other tab, and then switch back to the original tab. That way focus will be put back too.

Expected Results:  
Every keystroke should trigger an alert/confirm; viz. focus should automatically be put back on to the document after confirming the alert/confirm.
Dupe of Bug 617507?
(Reporter)

Comment 2

8 years ago
Dupe indeed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 617507
You need to log in before you can comment on or make changes to this bug.