Private browsing not working as intended when started from taskbar

RESOLVED INVALID

Status

()

Firefox
Private Browsing
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Cesare, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

When entering private browsing from the taskbar and performing a search from the address bar, when the results are displayed google profile will still be signed in, even if in private mode.

Reproducible: Always

Steps to Reproduce:
1. Start browser in private mode
2. Go to google.co.uk
3. Log in any google account
4. Close browser
5. Right click on the Firefox icon pinned on the taskbar and select Enter Private Browsing
6. Perform any search from the address bar
7. Wait for search results to show
8. Notice log in details in top right corner of the google page
Actual Results:  
In the search results the google profile stay signed in even if the user has connected in private mode

Expected Results:  
User shouldn't stay logged in

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110315 Firefox/4.0b13pre

Works fine for me. Tested in reported build and also the latest trunk build. Please try if it works fine by creating a new profile. 
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110315 Firefox/4.0b13pre
> 
> Works fine for me. Tested in reported build and also the latest trunk build.
> Please try if it works fine by creating a new profile. 
> https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.

When creating a new profile and trying to access the google website, or even typing 'google' in the search bar the browser hangs on the loading screen and the website is not displayed. Hard reset necessary closing the browser from task manager. I've tried creating a new profile 3 times with no luck. Also after rebooting the system, the same issue occurs.
Also, please note that with my original default profile I have no problem accessing the google website.
(Reporter)

Comment 3

7 years ago
I've actually just tried if the private browsing issue occurs even when disabling all my addons and I can confirm that the browser works fine in that case.
This might be caused by one of the addons, I guess.
(Reporter)

Comment 4

7 years ago
I've just found the addon that I think might be causing this issue: WebMail Notifier 2.7.5.
Disabling this addon the private browsing works fine.
When the addon is enabled and a gmail account is added to it, the google profile stays signed in,even in private mode.
Resolving as INVALID, since this is not a bug in Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.