Closed Bug 642042 Opened 9 years ago Closed 9 years ago

Fennec notification disappears and Downloads drop when switching networks between 3G & Wifi

Categories

(Firefox for Android Graveyard :: General, defect, P3)

ARM
Android
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 618316

People

(Reporter: tchung, Unassigned)

References

Details

Filing new bug since bug 609366 was fixed months ago.  In summary, trying to download a fennec update and switching networks will remove the notification and cancel the download progress.

regression?  need help digging for a range.

tested both 3G->Wifi & wifi->3G.   

Repro:
1) install Fennec android 3/14 build.  Mozilla/5.0 (Android; Linux armv71;
rv:2.0b13pre) Gecko/20110314 Firefox/4.0b13pre Fennec/4.0b6pre    
2) stay in wifi mode
3) launch fennec, search for updates.  3/15 update found, begin downloading
4) double check the fennec notification shows normal apk download progress bar
5) quickly, switch to 3G settings
6) Verify once 3G is switched on, the fennec download notification disappears.
7) perform steps 1-6, this time 3G->wifi.  Verify same.

Expected:
- switching network connections should not drop the download progress nor remove the fennec notification

Actual:
- notification disappears and downloads drop.
See Also: → 609366
Phone: Nexus S
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618316
forgot about this one.
Status: RESOLVED → VERIFIED
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.