If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash @ PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName

RESOLVED WORKSFORME

Status

()

Toolkit
Storage
--
critical
RESOLVED WORKSFORME
7 years ago
a year ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
It is a new crash signature that first appeared in 4.0b12.
It is #102 top crasher in 4.0RC1.

Signature	PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName(nsACString_internal const&, nsIVariant*)
UUID	abaadafc-100e-417e-8adc-62d3e2110315
Time 	2011-03-15 16:33:16.783351
Uptime	77
Last Crash	97 seconds before submission
Install Age	404454 seconds (4.7 days) since version was first installed.
Product	Firefox
Version	4.0
Build ID	20110303194838
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 15 model 6 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9498, AdapterDriverVersion: 8.632.1.2000
D3D10 Layers? D3D10 Layers-
D3D9 Layers? D3D9 Layers-

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.c:661
1 	xul.dll 	mozilla::storage::AsyncBindingParams::BindByName 	storage/src/mozStorageBindingParams.cpp:312
2 	xul.dll 	mozilla::storage::BindingParams::BindUTF8StringByName 	storage/src/mozStorageBindingParams.cpp:325
3 	xul.dll 	bindCookieParameters 	netwerk/cookie/nsCookieService.cpp:3733
4 		@0x9 	
5 	xul.dll 	nsCookieService::AddCookieToList 	netwerk/cookie/nsCookieService.cpp:3806
6 	xul.dll 	nsCookieService::AddInternal 	netwerk/cookie/nsCookieService.cpp:2736
7 	nspr4.dll 	nspr4.dll@0x1d0ef 	
8 	xul.dll 	nsCookieService::SetCookieInternal 	netwerk/cookie/nsCookieService.cpp:2616

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=PL_DHashTableOperate%20|%20mozilla%3A%3Astorage%3A%3AAsyncBindingParams%3A%3ABindByName%28nsACString_internal%20const%26%2C%20nsIVariant*%29
(Assignee)

Updated

6 years ago
Crash Signature: [@ PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName(nsACString_internal const&, nsIVariant*) ]
(Reporter)

Updated

6 years ago
Crash Signature: [@ PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName(nsACString_internal const&, nsIVariant*) ] → [@ PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName(nsACString_internal const&, nsIVariant*) ] [@ PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName ]
Summary: Crash [@ PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName(nsACString_internal const&, nsIVariant*) ] → Crash @ PL_DHashTableOperate | mozilla::storage::AsyncBindingParams::BindByName

Comment 1

a year ago
Closing this bug due to the fact that there are no crash reports with this signature in Socorro in the last 28 days.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.